No SDK available for your account


I tried to download JetPack 4.2. It starts downloading but failed on some components. After I restarted the SDK manager, it says “No SDK available for your account”.

Reinstalling the manager doesn’t solve the problem.

Hi hao.guo,

Are you login with NVIDIA DEVELOPER account?
Jetson users must use their Developer Zone account credentials in order to log in to SDK Manager

Please refer this link:[url][/url]

Totally the same problem.
I have got the developer account 4 months ago,
and surely there is “NVIDIA Developer Program” showed in my profile page.

However, at the very beginning of SDKManager,
it shows:

No SDKs are available for your account.
Verify that your NVIDIA account is registered to the correct development program on

OK, I tried for a second time to login and it was OK…

It’s good to know :)

Hi hao.guo, please tried to login again with your developer account. Thanks!

1 Like

Is “Developer Zone account credentials” the account for this forum? I can not find SDK in SDK Manager too. I am in China. thanks

1 Like

Don’t know what the true reason is. (Not the GFW)
Sometimes it works some time it does not.
Just try to login for several times…

I use my forum account to log in and log out for sveral times, but it does not work. Restart sdkmanager has no affect too.

Hi all, retries of login didn’t solve my problem, but I managed to get it works after a complete reinstall of SDK manager:

  1. sudo apt remove sdkmanager
  2. removed everything installed by sdkmanager: /opt/nvidia, ~/nvidia and ~/Downloads/nvidia(the download folder you set).
  3. sudo apt install sdkmanager_xxx.deb

And I could flash my TX2 now.

I’d also like to add a note:

By default, the SDK manager would install host toolchain, which might fail if you have installed different version of opencv/cuda. You need to remove opencv (sudo apt remove “opencv*”) and cuda toolkits before that step.

PS. Please consider adding TensorRT and other nvidia libraries as options in SDK manager. I still need to manually download these libraries after host toolchain setup.

Hi hao.guo,

Thanks for the suggestion, we wil check with internal team to see if can improve the user experience for SDK installation.


Hi~I encountered the problem and still get no result. Would you please help me out?
I downloaded the latest sdkmanager deb file ‘sdkmanager_0.9.11-3405_amd64.deb’.
I installed it by ‘sudo apt install ./sdkmanager_0.9.11-3405_amd64.deb’
After login via ‘’, I got the oops error ‘No sdks are available for your account’
I checked my membership information which shows as below: ‘nvidia developer program ID 874688’ and ‘accelerated computing developer program ID 873374’
I tried to login several time and reinstall the sdkmanager serveral times but still got the same error. Would you please help me out?

Or is there some offline installation package like jetpack 3.x I can get? Thanks.

Hi yanhnbupt,

Could you help to package ~/.nvsdkm folder for our debugging?


Solved it. Thanks.
It’s my host’s problem.
Either change the /etc/hosts file or /etc/resolv.conf file the help parse the ip address.

Hi, I face the same issue:

No SDKs are available for your account. Verify your NVIDIA account is registered to the correct development program on

Actually, as I check my SDK Manager Membership Information, I see: NVIDIA Developer Program, ID: 874688

How may I solve the issue?

Attached zip file is the .nvsdkm foldr.

Thanks. (3.63 KB)

Hi akzare,

What’s the platform you’re using? Can the problem still present?


Same problem here.

I don’t why I can’t upload the sdk log here. But the problem is the no sdks available too.

----------------------------------log --------------------------------------------

*********************************** SDK Manager initialized ***********************************
2019-08-14 14:08:37.485 - info: Time: 2019-08-14_14:08:37
2019-08-14 14:08:37.485 - info: Client: UI
2019-08-14 14:08:37.485 - info: **********************************************************************

2019-08-14 14:08:37.485 - info: images path /opt/nvidia/sdkmanager/resources/app/output/dist/electron/images/
2019-08-14 14:08:39.006 - info: forking worker process
2019-08-14 14:08:39.013 - info: initializing the download service
2019-08-14 14:08:39.020 - info: forking a child process for the download service pid 4332
2019-08-14 14:08:39.046 - info: Initializing download manager with 6
2019-08-14 14:08:39.355 - info: Ignoring QNX toolchain.
2019-08-14 14:08:39.392 - info: Begin to create timing task for auto update.
2019-08-14 14:08:39.433 - info: Host OS: Ubuntu1604
2019-08-14 14:08:39.434 - info: packageJson: /opt/nvidia/sdkmanager/resources/app/package.json
2019-08-14 14:08:39.454 - info: [Download Service]:loading the download service
initialized download service
got heartbeat request

2019-08-14 14:08:39.455 - info: download service is alive
2019-08-14 14:08:39.469 - info: config:
{ mainRepoURL: ‘’,
PIDServer: ‘P’,
DevZoneServer: ‘P’ }
2019-08-14 14:08:39.473 - info: initDevzoneTab…
2019-08-14 14:08:39.475 - info: requesting WebContents…
2019-08-14 14:08:39.484 - info: trying to autologin with already signed in user
2019-08-14 14:08:39.537 - info: token has not yet expired, validating with sso
2019-08-14 14:08:39.537 - info: Logging in…
2019-08-14 14:08:39.538 - info: get user programs. url:
2019-08-14 14:08:39.546 - info: manifest: {“name”:“sdkmanager”,“version”:“0.9.13”,“releaseVersion”:“0.9.13”,“revision”:“0”,“releaseRevision”:“0”,“buildNumber”:“4763”,“releaseBuild”:“4763”,“release”:false}
2019-08-14 14:08:39.546 - info: Setting GA parameters: title SDK Manager version 0.9.13 dev: 0 internal: false
2019-08-14 14:08:39.552 - info: Initializing GA analytics: SDK Manager 0 false
2019-08-14 14:08:39.553 - info: Initialized GA visitor with: TrackID: UA-59254929-46 UserID 568121bf-663f-5d81-ab8a-584f147d49ba
2019-08-14 14:08:39.553 - info: GA analytics: setting custom dimensions: UserType, SDKMode, SDKMVersion External UI
2019-08-14 14:08:39.560 - info: mainRepoUrl:
2019-08-14 14:08:39.560 - info: logging in with l1 url:
2019-08-14 14:08:39.628 - info: Create timing task for auto update successfully.
2019-08-14 14:08:45.693 - info: the DevZone programs that user can access:
2019-08-14 14:08:45.693 - info: { id: 874688, name: NVIDIA Developer Program }
2019-08-14 14:08:45.704 - info: Retrieving Data…
2019-08-14 14:08:45.706 - info: Processing Data…
2019-08-14 14:08:45.709 - info: Loading data from server: l1url. Url:
2019-08-14 14:08:45.711 - info: logging sso server type to GA
2019-08-14 14:08:58.297 - error: sdkml1_repo.json download failed with error ETIMEDOUT, request url:
2019-08-14 14:08:58.297 - error:
Error { code: ‘ETIMEDOUT’, messsage: ‘ETIMEDOUT’ }
2019-08-14 14:08:58.298 - error:
Error {
message: ‘Parse Level 1 Repo failed’,
stack: ‘Error: Parse Level 1 Repo failed\n at file:///opt/nvidia/sdkmanager/resources/app/output/dist/electron/renderer.js:1123:6533\n at ’ }
2019-08-14 14:08:58.299 - error: failed to initialize data manager. Error:
Error {
message: ‘Parse Level 1 Repo failed’,
stack: ‘Error: Parse Level 1 Repo failed\n at file:///opt/nvidia/sdkmanager/resources/app/output/dist/electron/renderer.js:1123:6533\n at ’ }
2019-08-14 14:09:34.800 - info: exporting logs from /home/zhaoqun/.nvsdkm/logs
2019-08-14 14:09:34.802 - error: Cannot find the root folder /home/zhaoqun/.nvsdkm/replays
2019-08-14 14:09:34.945 - info: Exported 2 log files to /home/zhaoqun/Downloads/nvidia/sdkm_downloads/

HI zhongzhaoqun1991,

Issue should be resolved, please try again.


I am experiencing a similar problem to this. I have read through this forum and have tried everything recommended, restarting, reinstalling, rebooting, no luck.

When I launch SDK Manager after logging in it tells me “OOPS! No SDKs are available for your account” I have created an account and I have joined the NVIDIA Developer Program. Am I missing a step to gain access? I have a Jetson TX2 which I would like to start developing on.

OS:UBUNTU 16.04.6

SDK Manager

The GUI app does not always make it obvious that there are two different login portals. Make sure you are not trying to log in to the NVIDIA partner site.

Thank you, yes I have been logging in to via the app.