No Signal Issue with NVIDIA 1070 on ASUS

I have a problem with my NVIDIA GTX 1070 connecting to my Asus VP28UQG via HDMI 1. Whenever I power on my PC with the card, I receive a “No signal” error unless I have the monitor already on the correct input. Similarly, if I login (I am on Ubuntu 18.04 using lightdm), and I change the input on monitor to HDMI 2 or DisplayPort, then when I go back to HDMI 1 the signal is lost and I have to reboot my PC. Rebooting my PC and making sure the monitor is on the correct input is the only solution I found to this which is unideal.

this issue does not happen with my windows laptop connected to the same monitor, I have tried two different HDMI cables, and the cables work elsewhere so I believe it could be NVIDIA (and/or lightdm issue). I recently updated drivers to version 460.91.03 (which helped fix a prior issue making the resolution back to normal) and I recently installed CUDA 11.2; I do not remember this happening before CUDA was installed and I tried uninstalling it but still the issue persists.

Basically, I only successfully receive signal to the monitor if and only if I have the monitor on the correct input when my PC boots up and I cannot change out of that input and back in to it.

Any ideas? Let me know if I am missing key information in my post