NO sound using DisplayPort audio with 375.82, 384.59 and 384.69

387.12 fixes my DP audio issue.

387.12 doesn’t work for me; in fact, now I don’t even see HDMI audio as an option, the nvidia sound card has completely disappeared from my system I think.

387.12 works fine with my GTX 690. Thanks!

I think fix for this available in next driver release and it will be available soon.

387.22 no audio dp

I think your issue may be related to this bug here
https://devtalk.nvidia.com/default/topic/1024022/linux/gtx-1060-no-audio-over-hdmi-only-hda-intel-detected-azalia/

I was following this topic instead and this appears to be another issue

modesetting=1 and prime sync is working so well for me, I almost forgot that I can use BIOS to set discrete graphics mode.
When I do this, I see NVidia HDA device output. I’m told that ‘HDMI 2’ is plugged in, and using that, I get audio over my display port connection to to my monitor.

So that’s great. But it doesn’t work when I’m in hybrid graphics, which I like to use since it’s a faster switch to low-power intel-only than flipping in BIOS.

Using the short lived branch 387.22 driver instead of the long lived branch 384.98 driver fixed the sound issue for me on my CentOS 7.4 box with NVS 510

Neither 387.12, 387.22, 384.98 solved it. I have a GTX 1070, Acer XZ350CU and no audio output is detected.

confirmed broken in 384.90, however this is working perfectly with 375.66

Thank you NVIDIA for support !

Fedora 27 Gnome

384.69 no audio dp
384.90 no audio dp
387.12 no audio dp
387.22 no audio dp
384.98 no audio dp
387.34 no audio dp
390.12 no audio dp

I’ve got some solution guys, I hope it works for some of you as well: I configured my monitor as DP1.1 (disabled DP1.2) and now the monitor device appears in my Sound Output list and sound works fine too.

I guess it’s related to this https://devtalk.nvidia.com/default/topic/982613/eld-is-not-valid-so-i-can-t-use-hdmi-dp-audio , it seems that multistream transport isn’t supported.

Hi thx for suggestions but this not works for me i have dell u34w http://www.dell.com/en-us/work/shop/dell-34-ultrasharp-curved-monitor-u3417w/apd/210-adtr/monitors-monitor-accessories
Input Connectors
1 DP 1.2 (HDCP 1.4) / 1 mDP 1.2 (HDCP 1.4) / 1 DP 1.2 (out) with MST (HDCP 1.4) / 1 HDMI 1.4 (MHL 2.0) / 1 HDMI 2.0 (HDCP 1.4) / 4 USB 3.0 downstream ports with 1 x BC1.2 charging capability at 2A (max) / 2 USB 3.0 upstream ports
and like you see dp1.1 not support resolution 3440x1440 60hz
https://en.wikipedia.org/wiki/DisplayPort

wtf still no news ?

I dug a bit into what michael.valenciav mentioned about the missing support of audio over DP MST and it seems that’s a kernel problem. Dave Arlie made patches for that but those were ignored and still not in kernel because nobody cared:
http://www.spinics.net/lists/intel-gfx/msg68973.html

Hi thx for info
after reported bug to bugzilla.redhat.com
the answer is :
I’m sorry but we do not support the binary NVIDIA drivers, please ask for support in NVIDIA’s forums.

what now ?

Afaik, HDMI audio is handled by snd-hda-intel driver which is developed at alsa project. Either ask there about general DP MST support or Dave Airlie where he has given up.

A (not very hopeful) update. I was looking info about the kernel (as generix suggested) and in fact I found that DP MST support is added in kernel 4.11 (https://www.phoronix.com/scan.php?page=article&item=linux-411-features&num=1). My current kernel version at the time was 4.10 so I upgraded to 4.14.5 (latest stable), reinstalled the Nvidia driver 387.34 … but everything works just like before: only getting audio over DP1.1 :(

Maybe it’s because i have a Ryzen processor, i don’t know…

At least this shows that my impression that the kernel was lacking mst audio support in general was wrong, it was obviously added. So we’re back to the state that nvidia has to make use of it and add it to their drivers, too. So far only intel gpus support this. Don’t know about amd.
Since this was initially a thread about DP audio not working at all, maybe open another thread with a more relevant title asking about mst audio support.

I’m using Display Port to connect my laptop to a LG Ultrawide monitor. With NVidia driver version 340.102, sound was working perfectly. Now with 384.111, no sound!

Linux kernel  : 4.13.0-26
NVidia card   : GK106GLM (Quadro K1200M)
NVidia driver : 384.111