Not able to run deepstream-test1 example

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU) - Tesla T4 **
• DeepStream Version - Deepstream-6.2
• JetPack Version (valid for Jetson only)
• TensorRT Version -
• NVIDIA GPU Driver Version (valid for GPU only) - 525.85.12
• Issue Type( questions, new requirements, bugs) - Query
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I am trying to run the deepstream-test1 sample example present at deepstream_python_apps/apps/deepstream-test1 at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub.
I followed the README file and ran the command “python3 ./ …/…/…/samples/streams/sample_1080p_h264.h264” and got the error “ModuleNotFoundError: No module named ‘pyds’”. My Python version is 3.8.10 and my Deepstream version is 6.2. Do I need to explicitly install all the modules expected by the example or they all be found somewhere? Am I missing something?

Did you install the wheel?
The wheel file for DS62 can be downloaded on link Releases · NVIDIA-AI-IOT/deepstream_python_apps · GitHub .

I will try the example once with the wheel file for DS62.
On a different note, I also tried running the C++ version of the example (Came pre-installed with the docker I downloaded). When I run the example, I do see the inference getting printed on the console but not as bounding boxes on the video.
When I run the example, I do see the video trying to come up but also closing immediately. I also observed the following error in the running logs -
0:00:04.031153770 507 0x55d8e24304c0 WARN nvinfer gstnvinfer.cpp:2369:gst_nvinfer_output_loop: error: Internal data stream error.
0:00:04.031170288 507 0x55d8e24304c0 WARN nvinfer gstnvinfer.cpp:2369:gst_nvinfer_output_loop: error: streaming stopped, reason not-negotiated (-4)
ERROR from element primary-nvinference-engine: Internal data stream error.
Error details: gstnvinfer.cpp(2369): gst_nvinfer_output_loop (): /GstPipeline:dstest1-pipeline/GstNvInfer:primary-nvinference-engine:
Can you please suggest what am I missing?

Is this test run in the docker or in native environment?
You can add “GST_DEBUG=3” ahead of your command to get more logs.

If you are working in the DeepStream6.2 docker, the most convenient way to install python samples is to use script mentioned here: DeepStream 6.2 is now available for download! - #3 by yingliu

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

Are you running the sample in docker ?

run this command

xhost +

docker run --gpus all -it --rm --net=host --privileged -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.2

Allow external applications to connect to the host’s X display

here is same refer information about DeepStream Docker

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.