nSight 4.6 crashes app immediately when starting performance analysis. Visual studio 2012, Dx11

CreateSwapChain is failing.

It appears that nsight is attempting to grab a swap buffer off the swap chain that does not exist, at some point during the swap chain creation.

The chain is created with DISCARD and double buffered and it outputs the error:
DXGI ERROR: IDXGISwapChain::GetBuffer: iBuffer must be zero if swap effect is DXGI_SWAP_EFFECT_DISCARD. [ MISCELLANEOUS ERROR #11: ]

If the buffer is created in sequential mode then it outputs this error.
DXGI ERROR: IDXGISwapChain::GetBuffer: iBuffer is larger than actual number of buffers. [ MISCELLANEOUS ERROR #12: ]

I have tried allocating more buffers and making it single buffered and neither seem to have any effect. So it appears to be trying to access a buffer index past the end of any I have created. This error is only encountered when nSight activities are running.


nSight ( with driver 347.88) was working fine after the initial install. However, the game slowed to 1/2 the regular speed and this appeared to be all driver and GPU time. So I investigated to see whether it was nSight or the driver version change.

I disabled nSight instrumentation via the options, this had no effect and did not appear to prevent captures either. ???

I changed drivers to latest, and it was still slow.

So I uninstalled nSight which solved the slowness problem. When I reinstalled nSight, nSight was unable to debug any DX activity without crashing.

During the first run of nSight I was able to find some useful bottlenecks and fix them, however reverting these fixes also had no effect on this crash. I would love to continue profiling the game however that is now impossible on this machine.

I have tried uninstalling and reinstalling, nSight and the driver in different orders as well as cleaning up the directories created by nSight. None of this has had any effect in allowing me to debug again.

George Davison,
Principal Graphics Engineer
Runic Games

Hi George,

We have received your email, let us discuss in the mail.


Did this ever get fixed? we’re running into it here, on both 4.6 and 4.7.

Hi jallensworth,

Not sure your issue is the same as darkfred or have any related with darkfred’s.

Can we have your sample to do some investigation/repro?


In my case the installer was broken. I fixed it previously by simply doing a full uninstall/reinstall with a reboot at each step of both the driver and nsight. Unfortunately I am hitting the same issue again with the 4.7 update. So I am going to try the entire process again. I will report on my results.