NSight-Compute with Jetson AGX Xavier

So I have setup my new Jetson AGX Xavier with the JetPack SDK Manager and my host machine got CUDA and NSight System profiler. I was able to run the NSight System profiler from my host machine and profile an application on the Jetson. But when I tried to use the NSight Compute profiler when it trys to connect to my Jetson over SSH it does the following:

Launching: ./hologram (host:
Process launched
Trying to connect to process...
Trying to connect to process on host:
ERROR: ld.so: object '/tmp/var/target/linux-desktop-glibc_2_11_3-glx-x64/libcuda-injection.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

Trying to connect to process on host:
Trying to connect to process on host:
Process exited

I also tried running an application using NSight-Graphics and got the following error:

Trying to connect to process on host:
No protocol specified
terminate called after throwing an instance of 'std::runtime_error'

  what():  Pangolin X11: Failed to open X display

Trying to connect to process on host:
Trying to connect to process on host:

Are there any resources available that shows how to use NSight-Compute and NSight-Graphics with the Jetson? Also, do you guys have any idea as to what could be causing these errors?


Please noticed that you will need to login with root authority to enable cross-profiling.
Do you ssh the device with root account?


Yes we are using root when sshing into the device.

Hey AastaLLL,

Any update on this? This is sort of time critical for me.

Thanks a lot!


Sorry for the late update.

Are you trying to enable a local window from your application.
Please noticed that you may not able to redirect a local window via ssh profiling.

Would you mind to disable the output window to see if helps?


Hi huzi,

Have you managed to get issue resolved? Any result can be shared?