Nsight crashes with CentOS 6.6

Yum updated me to a version of software which no longer appears to be compatible with nsight.

The automatic bug reporting tool references java-1.7.0-openjdk- and indicates that it was killed by a signal 6 (SIGABRT). This originally occurred when opening the existing workspace, so I created a new workspace and imported all the projects. This built, but a crash occurred when I opened a file for edit.

I have looked on the web for an answer and found none. Has anyone solved this problem?

I guess I see a few paths I can take:

  1. Back off to an earlier version of CentOS. Not pretty, lots of things installed here and lots of projects underway.

  2. Try to find a way to back off on Java or whatever else is deemed to be the root cause. I think I saw one post the said it was the version of the graphics package.

  3. Try to get the Nsight tools working from within the generic Eclipse version, which runs fine. Anyone try this?

  4. Wait for an updated release of Nsight. Anyone have an idea how long a wait this would be? I am more than willing to be a Beta tester.

  5. Edit using another tool and use Nsight just for building.



When run from an xterm, this error is displayed at the time of the crash:

java: cairo-misc.c:380: _cairo_operator_bounded_by_source: Assertion `NOT_REACHED’ failed.

The fix that seems to have worked is putting:


in /usr/local/cuda-6.5/libnsight/nsight.ini