NSight not able to connect to application

Hi,

I’m trying to debug my multi target application with NSight Graphics.
On two of my systems NSight is not able to connect to my application, it crashes after 77% when trying to capture a frame. This happens under DirectX, OpenGL, as well as Vulkan.

I assume that this issue was introduced with a Windows 10 Update, but I’m not sure about that. I tried to update my drivers, my Windows and NSight, no success. It also seems to be GPU independent. Currently I’m running a Quadro RTX 6000. But this issue also occurs under different cards.

“Automatically Connect” is set to ‘yes’ in my settings, but manually connecting also leads to the same issue.

Any advice what else I could try would be amazing!

Thanks in advance.

Best regards,
Vanessa

Hello,
Sorry you ran into this issue. Would it be possible to try using our latest release, Nsight Graphics 2020.3 and if you still run into an issue, you can send a hang report by following the instructions as discussed here: https://docs.nvidia.com/nsight-graphics/UserGuide/index.html#troubleshooting_manual_hang_reports. Nsight Graphics 2020.3 can be found at the following location https://developer.nvidia.com/nsight-graphics.

Hi,
thanks for your advice. Unfortunately the update didn’t help.
How should I create a hang report? Because it’s not hanging for me, but it crashes after 77% with “Connection error detected communicating with target application. Shutting down connection.”

Hi,

Sorry for the confusion. Have you already sent us a crash report? If you have already then please resend while also including your contact details so that we know which report to associate to you. If the crash dialog is not triggering for you, then please follow these instructions: https://docs.nvidia.com/nsight-graphics/UserGuide/index.html#troubleshooting_crash_reporting