Nvidia driver not playing nicely on fresh install of archlinux

I had Manjaro installed on my laptop for a year, and everything worked fine until a few weeks ago I did a system upgrade. TL;DR: I installed a fresh copy of archlinux. I chose to use gnome as I’m used to it. I followed the official guides to install the Nvidia driver and PRIME render offload.
But it still doesn’t work, and after looking at the logs and doing a bit of searching I found that some people fixed theirs by adding the Nvidia modules to mkinitcpio.conf. Trying that didn’t help at all.

lspci -k: lspci -k - Pastebin.com

archtop% prime-run glxinfo -B
name of display: :1
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  50
  Current serial number in output stream:  51

ive hit all the various issues over the period of a few weeks owning this laptop and summed up a general configuration here running archlinux probably applies to most distros tho. gist.md · GitHub see if there is something you are missing.

After setting up a windows environment, I can conclude that that 1050 is now officially toasted.