[SOLVED] Nvidia GPU not working on Arch Linux

After updating to Linux 6.0.1 my Nvidia GPU stopped working. When using nvidia-settings on the terminal I receive the message:
`(nvidia-settings:26696): GLib-GObject-CRITICAL **: 12:21:38.045: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

ERROR: A supplied argument is invalid
Here are my log files:
nvidia-bug-report.log.gz (1.1 MB)

I am on an Acer Nitro 5 laptop with an Intel iGPU and a Nvidia GTX1650 dGPU.

Thanks in advance.

SOLVED: I managed to solve the problem by using DRM and setting the Nvidia drivers to start early on boot.

Do you have more info on solving this issue? I also am using Arch and have the same issue, but have DRM, etc added to the mkinitcpio.conf.

Thanks in advance.

I discovered that you can use the nvidia-prime package to do a prime-run command to run programs on the Nvidia GPU. I do not think that this is a good solution, but it works.


prime-run steam-runtime

Edit: You need to use the command every time you want to use the program on the Nvidia GPU so it is very inconvenient.

using DRM is to set nvidia-drm.modeset=1 in the grub file??

How to set the nvidia drivers to start early on boot?