NVIDIA GeForce GTX 1650 SUPER CUDA

I’m a complete novice when it comes to computer systems and hardware. I have a Dell XPS 8940 desktop (Windows 10, 64-bit operating system, x64-based processor) with an Intel UHD Graphics 630 card and a NVIDIA GeForce GTX 1650 SUPER card. Recently, I installed Daz Studio 4.15 with NVIDIA Iray. CUDA is a requirement for Iray. Question 1) My NVIDIA card is CUDA-enabled correct? Question 2) I need to download and install CUDA Toolkit 11.3 for CUDA correct? Thanks for your time. Bests.

Moving this topic to the CUDA forum for greater visibility.

You can check all capabilities of both GPUs with GPU-Z if you ever have trouble.

You do not need the toolkit for applications that you bought.

You need the toolkit only for programmes which you develop yourself or come as “source code” on whatever developer site.

Maybe the link will help you!!!
https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

Downloaded GPU-Z. For the NVIDIA GeForce GTX 1650 SUPER card, the CUDA box is checked. Does that mean CUDA is installed? I’m sure all this computer hardware will make sense to me once I have some experience with 3D rendering; however, at the moment, it is as the saying goes, “It’s all Greek to me.” LOL. Bests.

Then driver installation is OK
Now check this guide:

https://nvidia.custhelp.com/app/answers/detail/a_id/5188/#29

Went to the webpage. In the first step under “Photoreal Devices” and “Interactive Devices” my NVIDIA card is listed as “CUDA-0 NVIDIA GeForce GTX 1650 SUPER.” In the second step (“Draw Settings - Editor - Filtering”) window "Post Denoiser Available” and “Post Denoiser Enable” are not listed, only “Fireflies,” “Noise,” and “Bloom.” Btw, thanks for responding and helping.

I found “Post Denoiser.” In the newest Daz Studio 4.15 version (downloaded 4/17/2021), “Post Denoiser” is not located in “Draw Settings” > “Editor” > “Filtering” as described in https://nvidia.custhelp.com/app/answers/detail/a_id/5188/#29. Instead it is located in “Render Settings” > “Editor” > “Filtering.” Thought I would mention this in case someone else is having difficultly finding “Post Denoiser.”