NVIDIA GeForce RTC 3090 on Ubuntu 20.04.02

Hi all,

There is an Ubuntu 20.04.02 OS and external GPU NVIDIA GeForce RTX 3090 connected with Razer Core X Chroma.
When I try to install drivers both from Software&Updates and from the terminal using command:
sudo apt install nvidia-driver-470

I see error message:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
nvidia-driver-470 : Depends: libnvidia-gl-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: libnvidia-extra-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: nvidia-compute-utils-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: libnvidia-decode-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: libnvidia-encode-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: nvidia-utils-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: xserver-xorg-video-nvidia-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: libnvidia-cfg1-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: libnvidia-ifr1-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Depends: libnvidia-fbc1-470 (= 470.57.02-0ubuntu0.20.04.1) but it is not going to be installed
Recommends: nvidia-settings but it is not going to be installed
Recommends: libnvidia-compute-470:i386 (= 470.57.02-0ubuntu0.20.04.1)
Recommends: libnvidia-decode-470:i386 (= 470.57.02-0ubuntu0.20.04.1)
Recommends: libnvidia-encode-470:i386 (= 470.57.02-0ubuntu0.20.04.1)
Recommends: libnvidia-ifr1-470:i386 (= 470.57.02-0ubuntu0.20.04.1)
Recommends: libnvidia-fbc1-470:i386 (= 470.57.02-0ubuntu0.20.04.1)
Recommends: libnvidia-gl-470:i386 (= 470.57.02-0ubuntu0.20.04.1)
E: Unable to correct problems, you have held broken packages.

May you please advice how to install drivers?

Thanks

Can you try to use the latest available (470) drivers from Additional drivers section under GUI?

Hi, Thanks, I used Software & Updates, then additional drivers and it showed this error

My colleague advised the terminal command:

sudo apt install nvidia-driver-470 --no-install-recommends

and it worked

1 Like