Nvidia orin nx FFPMPEG h264 hw encoding


I have been trying use HW accelerated h264 encoding on my nvidia oring NX without any success. it seems that i am missing the needed nvect libraries, but i could not find how to install it.
I have tried the following links:
https://doi cs.nvidia.com/video-technologies/video-codec-sdk/11.0/ffmpeg-with-nvidia-gpu/index.html
After following the insntructions, i got the below error:
[h264 @ 0xaaaafd1a5c40] Cannot load libnvcuvid.so.1
[h264 @ 0xaaaafd1a5c40] Failed loading nvcuvid.
[h264 @ 0xaaaafd1a5c40] Failed setup for format cuda: hwaccel initialisation returned error.
[h264_nvenc @ 0xaaaafc6b03d0] Cannot load libnvidia-encode.so.1
[h264_nvenc @ 0xaaaafc6b03d0] The minimum required Nvidia driver for nvenc is (unknown) or newer
[vost#0:0/h264_nvenc @ 0xaaaafc6b00e0] Error while opening encoder - maybe incorrect parameters such as bit_rate, rate, width or height.
[vf#0:0 @ 0xaaaafc5f1660] Error sending frames to consumers: Operation not permitted
[vf#0:0 @ 0xaaaafc5f1660] Task finished with error code: -1 (Operation not permitted)
[vf#0:0 @ 0xaaaafc5f1660] Terminating thread with return code -1 (Operation not permitted)
[vost#0:0/h264_nvenc @ 0xaaaafc6b00e0] Could not open encoder before EOF
[vost#0:0/h264_nvenc @ 0xaaaafc6b00e0] Task finished with error code: -22 (Invalid argument)
[vost#0:0/h264_nvenc @ 0xaaaafc6b00e0] Terminating thread with return code -22 (Invalid argument)
[out#0/mp4 @ 0xaaaafc620240] Nothing was written into output file, because at least one of its streams received no packets.
frame= 0 fps=0.0 q=0.0 Lsize= 0kB time=N/A bitrate=N/A speed=N/A
Conversion failed!

I have also tried using https://developer.nvidia.com/nvidia-video-codec-sdk/download but the examples does not compile.

is possible to use the nvenc with ffmpeg on this board? if so how?



Welcome to the NVIDIA Developer forums! Your topic will be best served in the Jetson category.

I will move this over for visibility.


Sorry for the late response.
Is this still an issue to support? Any result can be shared?

Please note VIDEO CODEC SDK is not supported on Jetson platforms.

We have a package enabling hardware decoding. Please refer to the post:
【jetpack 5.1.2】Error while loading shared libraries: libnvbuf_utils.so.1.0.0 - #10 by DaneLLL

For using hardware encoders, we suggest use jetson_multimedia_api.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.