nvvp connect to remote server through an ssh proxy

Hi,

I have successfully used nvvp on a remote machine directly, but now
I’m trying to use nvvp using a remote server through an ssh proxy.

I have configured my .ssh/config to connect to the target machine (which has K20 GPUs).
The ssh connection in a terminal is OK (I can connect directly through the proxy), but when I try to connect inside nvvp, I get the error message:

Failed to connect sshd on “XXX:22”
org.eclipse.core.runtime.CoreException

Is there a way to make nvvp/eclipse verbose about why the ssh connection failed (kind of ssh -vvv) ?

Best regards,

Pierre

You refer to nvvp. Are you actually using nsight eclipse edition? Or nvvp? Or something else?

I’m refering to nvvp. I’m just trying to launch locally nvvp and then set up the remote connection to an end target machine which I can’t ssh directly (it is a computing node from a cluster).

I set up the ssh keys as well as my ssh config file, so that I can connect directly to the end machine through the login node (used as an ssh proxy).
The ssh connection works fine in a shell terminal, but not inside nvvp.

So the question is: how to make nvvp verbose (more verbose than just the connection failed) to track this problem.

Have you reviewed the documentation?

http://docs.nvidia.com/cuda/profiler-users-guide/index.html#remote-profiling

For example, do you have the same CUDA toolkit version installed on local and remote machines?

Hello all,

I’ve got a similar problem with Nsight
trying to set remote connection with target.

It’s ok with connect by ssh in terminal window
but from Nsight setting dialog window I receive
socket timeout message from proxy like:

“Failed to connect sshd on
ProxySOCKS5:
timeout: socket is not established”

What wrong with ip setting on hots or remote side?

Thanks in advance.