[obsolete] Hardware hack for Wifi blocked by rfkill

this solution is obsolete, if you card is hardblocked by rfkill you can use gpio to activate wifi adapter:

sudo su
echo 191 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio191/direction
echo 1 > /sys/class/gpio/gpio191/value

Since (for now) Jetson TK1 does not correctly support rfkill for wifi card, we can try to hack hardware.

Tested with .

  1. mask pin 20 on bottom side wifi card

  1. compile kernel with required modules and add firmware (if required)

Guide: https://devtalk.nvidia.com/default/topic/762653/embedded-systems/-guide-build-own-kernel-for-jetson-tk1/

  1. well done :) wifi is working

  1. Tested wifi cards:

Working adapters with mask pin 20:

  • Atheros ATH-AR5B95

Not working adapters with mask pin 20:

  • Intel Centrino Wireless-N 2230 - something wrong with my adapter or bug in kernel

Very good to know, thanks for this!

What size are the screws for the mpcie slot?

I have not tried to use them, but I did gauge them by eye. I’m almost certain they are #2-56 x 1/8". Note that the specification for mPCIe boards is 100 mil, or 0.1", while 1/8" is 125 mil (). My “eyeball gauge” estimate is probably correct if the threads are not metric. I’d try #2-56 but do not have any handy. Total length of a bit over 1/8" is probably good. I’d like to know if someone gets to test this.

this solution is obsolete, you can use gpio to activate wifi (first post updated)

Hi
Have a Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01), and have tried following your advice… cannot make it work. What modules do I have to load to activate it?
Output:
rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
(This correspond to my EDIMAX USB dongle, which is working)

lspci
01:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Thanks

i have these same wifi card and fully working:

01:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

my lsmod:

Module                  Size  Used by
joydev                  8199  0 
dm_crypt               12216  0 
bnep                   11872  2 
rfcomm                 46483  0 
bluetooth             279594  10 bnep,rfcomm
ath9k                  91267  0 
ath9k_common            1711  1 ath9k
ath9k_hw              363960  2 ath9k_common,ath9k
ath                    13842  3 ath9k_common,ath9k,ath9k_hw
mac80211              351412  1 ath9k
cfg80211              349795  3 ath,ath9k,mac80211
rfkill                 14634  5 cfg80211,bluetooth

did you try Grinch Custom Kernel?

Thanks… After searching a bit I found this one:

backports: Linux kernel backports
http://drvbp1.linux-foundation.org/~mcgrof/rel-html/backports/

And with your instructions for rfkill it seems to work…
(Well i’m having some problems connecting to the actual wireless network, but at least I can see the module and unblock it…)

Thanks

By the way - no I haven’t tried it (yet) - Look cool. Next time I’m about to do a re-flash (and wipe all I got on there now) I’ll definitely try it… :-)
Keep up the good work!

Hi Santyago,

Good work…
Ok, had not not seen the re-flash option without having to wipe the TK1… Now I got it working with the Atheros AR9285 (and I’m able to connect to a network ;-)
Thanks again! You are awesome…