Omniverse download page not working, is there an alternate download page?

The Omniverse download page:

(clearly shows en-us as the localization parameter)

When you click the download button for Individual License it shows a registration form that is half in English and half in a Chinese looking language. As such it is not possible to complete the registration form or to download ominiverse).

Is there another way to download the individual license version? Or anybody from nvidia monitoring the forum who might be able to fix the download page?

1 Like

try en-gb instead of en-us

Download works fine on en-gb page:

Page is still broken, any fix?

@Pixel452 what’s the full page URL you see that on, can you link it here? is it en-us? because i can confirm en-us page has consistent language and is working fine on my end.

I tried a bunch, but they’re all broken in the same way

this the full link:

1 Like

thanks for sending that. i wondering if it’s browser-based problem; can you say which browser are you using? and have you tried clearing out cache/cookies? below is what i am seeing on chromium (standard and enterprise/cloud) and what’s odd is the fields are completely different



I tried:

Edge: 115.0.1901.203
Chrome: 116.0.5845.97


Cleared cache and Private Mode, that should not cache anything at all, same result all the time.
I also tried Tor, but it blocked me.

Is there any other way to get the file?

One more thing, I’m trying the Free option

I have the same problem when trying to update the launcher.

@xanavia this could be a localization bug. do you mind letting the devs know where you are connecting from?

Hi @Simplychenable @xanavia I’m trying from France and I have the exact same problem

Trying this from the UK

Running into the same issue here. Switching to en-gb doesn’t budge it.