Cannot sign URL for download -- FetchError: request to https://api.launcher.omniverse.nvidia.com

Server Installation Is In Progress.
Click On the Link To Walk Through The Collaboration Process: DOCUMENTATION

Error: [e717806e-7e0e-49a1-a084-00c557f93584] Cannot sign URL for download – FetchError: request to https://api.launcher.omniverse.nvidia.com/app/url?path=https%3A%2F%2Flauncher-prod.s3.us-east-2.amazonaws.com%2Fnucleus-workstation%2F2021.3.2%2Fwindows-x86_64%2Fpackage.zip failed, reason: connect ETIMEDOUT 18.65.200.23:443

Hi @user160051! Welcome to the community! Sorry to hear you are having trouble. Based on the information you gave me, it looks like there is an issue connecting with the Nucleus server, but I need some more information to help figure out why.

Please attached your full logs found here:

  • Omniverse Launcher Logs: C:\Users\<USERNAME>\.nvidia-omniverse\logs\launcher
  • Nucleus Logs: %HOMEPATH%\.nvidia-omniverse\logs

Also, what is your computer environment?

  • Operating System
  • GPU / GPU Driver

I’m having the same issues, can’t install any apps through Omniverse Launcher → Error occurred during installation of Cache: [f773af83-3bd8-4222-b724-2e0a0e933166] Cannot sign URL for download – FetchError: request to https://api.launcher.omniverse.nvidia.com/app/url?path=https%3A%2F%2Flauncher-prod.s3.us-east-2.amazonaws.com%2Fcache%2F2021.3.0%2Fwindows-x86_64%2Fpackage.zip failed, reason: getaddrinfo ENOTFOUND api.launcher.omniverse.nvidia.com

I resolved this problem, this problem is within Windows 10/11 system didn’t support UTF-8, user need manually enable this setting

Step1: Delete Cache file
Step2: Go to the windows setting and search "Change Country and Region“
Step3: On the language part you can find a setting call Administrative language Settings (On the Right side of window)
Step4: On The language of non-Unicode programs, click change system location setting
Step5: Enable "use Unicode UTF-8 (Beta)

Restart PC and reinstall Cache
Make sure you delete old cache folder