Omniverse Houdini Connector docker errors


I’m attempting to add the Omniverse Connector plugin to our Houdini docker container but we’re getting some issues.
On my new Linux machine (not docker) using sudo on my user account for this process, I’ve been able to install the latest version of Houdini, copy the “houdini-connector-102.1.0” folder to the packages folder in the Houdini install directory (/opt/hfs19.5/packages) and run the I’ve been able to load up Hython in my terminal and import the homni and omni libraries and query the nucleus server. There are no other Omniverse files or programs on the machine except for the connector plugin folder.

When i try to repeat this process on Docker i get an error saying no such file or directory for a file called

I can see that the file does exist on the system and despite the plugin installed the exact same way as it was on my Linux machine, i’m getting different outcomes. The only difference being the user in the docker container being the root user.
I added print statements in the shiboken py file that’s throwing the error to pin point the error being from the homni module. The file being binary, i can’t tell why it can’t see the file and there are no readable files in that module that would be able to help me figure this out.

For the install of Houdini it’s the standard Linux install with the only additional option/arg. This is the install line from the Houdini docker file which is available on the sidefx website.
./houdiniInstaller/houdini*/houdini.install --auto-install --install-bin-symlink --accept-EULA ${EULA_DATE} \

We’re using the docker file from the sidefx website with the only changes being adding the plugin file and running the “” file.


Hello @jacob73
Could you please give v.102.4 a try? We fixed some compatible issues between Houdini patch versions. Although you mentioned that it works fine for you in a non-docker environment, I don’t think it is Houdini versions related issue, but let’s give it a try.

Another thing I would check is, in your docker environment, does your Houdini lib paths are included in PATH and/or LD_LIBRARY_PATH?

Ah yes! setting LD_LIBRARY_PATH fixes that issue. We just tested this solution not long before your post.
But having conquered that when we try to connect to the nucleus server with the reconnect function we get thrown an error from xdg-open requesting a TUI web browser for www-browser and listing some packages such as elink, w3m, lynx, links etc. These packages are OLD with most not receiving an update since 2009/2013 and required ubuntu packages having been versioned up since ubuntu 12-18.

We’ve installed links but we get thrown an error saying that it doesn’t support javascript. But none of these TUI web browsers really support javascript and all of them has issues when compiling them to enable javascript. Is there a way to connect to nucleus without the need for javascript?