Orin drive kit, rig file help?

Please provide the following info (tick the boxes after creating this topic):
Software Version
[*] DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System
[*] Linux

Hardware Platform
[*] DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version
[*] 1.9.10816

Host Machine Version
[*] native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

Dear @Richard.Zhang,
Could you check DriveWorks SDK Reference: Rig File Format for details on Rig file format?

I plug a camera to group B, 0 interface, and this is my rig file, but it does not work.

Dear @Richard.Zhang,
Is it working when connected to A0 port? Are you running sample_camera?

Yes, it workd with A0 port . However, it did not work with B0, I dont know what’s wrong with it?

Dear @Richard.Zhang,
Could you check below and update.

  • Try running camera sample from Nvmedia when camera is connected to B/C/D ports. Please see the commands at AR0820 Using 1 Lane CPHY | NVIDIA Docs
  • Try changing the camera of same module different module and see if it works on B/C/D ports using DW camera sample.

@SivaRamaKrishnaNV thx for replying, it works fine with nvmidea command.but the problem mentioned above is still exist, i am not sure if there is something wrong with the rig file.


Dear @Richard.Zhang,
So the issue does not occur on port B with nvmedia sample. Please paste the complete log as a text message or attachment.

Also, please confirm if DW camera sample works with other other camera modules and ports. This help to narrow down the route cause.

Dear @Richard.Zhang,
Please share your rig files/log files as text or attachments…

Dear @SivaRamaKrishnaNV
rig_test.json (1.1 KB)

Dear @SivaRamaKrishnaNV , I connected the camera on port C0 this time.

Dear @SivaRamaKrishnaNV
log (8.6 KB)

Dear @SivaRamaKrishnaNV , thx very much, i solved the problem.

Dear @Richard.Zhang,
Glad to hear the issue is fixed. Could you share what fixed the issue to help others in community

Dear @SivaRamaKrishnaNV , I tried camera parameter “interface=csi-e,” while i connected camera to “C0”, the application sample_camera could connect the camera.It’s so weird that the group name is not relevant to the interface parameter.

Dear @Richard.Zhang,
Could you check using interface=csi-(ab|cd|ef|gh), CPHY-mode=1 for A,B,C and D ports respectively. Let us know if it works.