Orin Nano can not start up, the power led can not flash


I have been working with Nano for 2-3 days without any problems However, now, when I power on Orin Nano, neither the power led nor fan works. Also, any information can not be displayed on the screen via the display port. I checked the power supply and the output of the dc to dc converters and realized that there are many elements that give 5V and 3.3V by measuring the multimeter. I tried the recovery method given in the user guide. What is the reason for this awkward situation?

I don’t know enough about specific test points to tell you everything to test. It isn’t unusual though for a carrier board to fail, while the module itself remains functional. If there is a problem though, it is usually the power supply regulation quality. A previously working power supply might simply not have high enough quality of regulation at some time despite having worked the day before. I’ve not seen that with one of the supplies which comes with a Jetson though. Is this the original power supply?

The other thing is that sometimes a peripheral causes failure indirectly (they consume power, and if they fail, they can consume more). See if the lights go on if you remove all peripherals. If they do, then add only serial console and see what happens (serial console won’t consume extra power as designed; the USB type is always self-powered for a Jetson).

If not, then it is likely the carrier board failed. You found several power points, but someone else might be able to tell you what all test points are for power. If all test points are good, then perhaps the module itself did fail.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.