Orin nano module won't flash: NV3P_SERVER: Failed to initialize partition table from GPT

I already had a working SSD with a different SoM on a custom carrier board, so I just needed to flash the QSPI on the new module so that it would boot the existing SSD.

Here’s the command I used to flash the QSPI:

sudo NO_RECOVERY_IMG=1 ./flash.sh -c bootloader/t186ref/cfg/flash_t234_qspi.xml jetson-orin-nano-devkit nvme0n1p1

It worked (seemingly) the first time. But then the board never booted, HDMI-attached monitor stayed blank.

I tried that same command a 2nd time and it failed with the following error:

[   7.9761 ] Writing partition secondary_gpt with gpt_secondary_3_0.bin [ 16896 bytes ]
[   7.9769 ] [................................................] 100%
[   7.9802 ] 000000004d4d2c01: E> NV3P_SERVER: Failed to initialize partition table from GPT.

I attached full host & uart loags for this.
Any help is super welcome!


command.log (74.8 KB)
uart.log (15.0 KB)


Please try initrd flash instead:

sudo ./tools/kernel_flash/l4t_initrd_flash.sh -p "--no-systemimg -c bootloader/t186ref/cfg/flash_t234_qspi.xml" --network usb0 jetson-orin-nano-devkit nvme0n1p1

It does look like some bug, and we are aware of it and tracking it, but it’s hard to proceed since it can only be re-produced on brand new modules, which we don’t quite have.

That method was able to flash the SoM’s QSPI.
Not sure if it would help root-causing the bug, but in my case, the carrier board does not have an EEPROM. I initially omitted to modify the MB2 BCT to reflect it, as instructed in Jetson AGX Orin Platform Adaptation and Bring-Up — Jetson Linux Developer Guide documentation

That said, once the module was in that state, only l4t_initrd_flash.sh was able to flash it, even after I fixed the MB2 BCT dtsi file

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.