Orin NX module question

Did I accidentally kill my orin NX module?
I tried to reboot the device with force recovery mode, the ssd is formated, but everytime it reboot it goes to UEFI shell. Tried to flash jetpack 5.1.1 again but host device can’t detect usb connection anymore.
Also tried with switch this module with a orin nano set that is fully working but still reboot in UEFI shell.
Here is the UART output when reboot.
data-out.txt (31.1 KB)

The module is still fine if UEFI shell could be entered.

The problem is after UEFI the things got broken. And after UEFI, it is your usb drive or nvme SSD.

Also, I don’t know if you are new to this or not. But did you remember to put the board into recovery mode when you try to flash from host? Or you are not sure what is recovery mode.

Hello Wayne, thanks for the reply! Yes I did put it in force recovery mode, and connect it to ubuntu host device by type-c. But even the host device can’t detect APX when it is in force recovery mode.

If I don’t put it in force recovery mode, the fan just start spinning immediately unlike in force recovery mode it stopped for a bit then start spinning.

I am using a nvme ssd for system flashing(for both orin nano and nx). Interesting feature for sdkmanager is that it doesn’t format the disk everytime I try to re-flash and leave a lot of partitions in the ssd, which cause the reboot after a successful flash fails in my case(I did fix the reboot issue on orin nano by format the ssd alone).

After orin NX goes to UEFI shell automatically when boot up, none of the usb port works when I try to connect a keyboard to it. But for GPIO ports we still able to see a 5v there

Do you have other orin nx devkit to validate whether if it is hardware problem?

For example, move this module from carrier board A to carrier board B or move another module from B to A.

Yes, I did validate the base board was okay, I moved the modular to the base board of jetson orin nano. The same behavior still happens. The orin nano module was totally okay on it’s own base board.

Could you share your method to put device into recovery mode?

I connect the force recovery pin under module with GND pin, which are the 3rd last and 4th last from the right. Connect type c to host device first than connect power supply.

Looks correct. Please RMA this device.

Thank you, do I just follow this link for RMA process?

1 Like

yes. Please follow the guidance in that link.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.