OS still using Renoir after installing nvidia drivers Ubuntu 18.04 RTX 3060 AMD64 ryzen 7


I am trying to install the nvidia drivers in my Ubuntu 18.04 with ASUS ROG Strix G15 Ryzen 7 Octa Core 5800H - (NVIDIA GeForce RTX 3060) G513QM-HN319TS

Everytime I install the nvidia drivers, it says to reboot and on reboot, It comes to black screen. When I purge remove the nvidia driver and reboot again, I am able to get back the Ubuntu GUI with nomodeset. or another way is switching to prime-select intel from safe-mode without uninstalling nvidia.
I solved this issue by adding patches from Ubuntu MATE 20.04 with RTX 3070 on Ryzen 5900 - black screen after boot - #30 by predte4a and Not able to install Nvidia drivers for my graphics card - #2 by Mart
I have tried installing nvidia-driver-460 and nvidia-driver-465 from all available methods with and without adding graphics-driver/ppa, using ubuntu-drivers autoinstall, using apt-get. I tried out these methods in both Ubuntu 20.04 and 18.04. My secure boot is disabled…

I tried updating the kernels also to 5.10.10,5.10.15, 5.10.16 but still no progress. Higher version of kernels need glibc version > 2.33 which does not come with Ubuntu 18.04.
Kindly help me out with this issue at the earliest and guide me towards how to best install the compatible drivers for my laptop, OS and graphics card.

nvidia-bug-report.log.gz (103.5 KB)

Thanks !

The “patch” doesn’t work anymore since the upstream file changed. You can try a 5.11.14 kernel which doesn’t need the patch and still installs on 20.04/18.04. Or better install 21.04 which works ootb on your machine.

yes with 5.11.X kernel versions on ubuntu 18.04 it is working but then there is issue with asus built in keyboard. I think I need to wait till I get a firmware update from asus. It keeps poping up power off action dialog on every key press. Though it is working fine with external keyboard. I can’t switch to ubuntu 21.04 because of ROS related complexities. Thanks for solution.

Then you can try this:

  • use a 5.10 kernel
  • apply the reconstructed patch:
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/plain/scripts/module.lds.S?h=v5.10.47 -O /usr/src/linux-headers-5.10.2-051002-generic/scripts/module.lds
sudo sed -i '$ d' /usr/src/linux-headers-5.10.2-051002-generic/scripts/module.lds

Make sure you put the correct kernel version instead of “5.10.2-051002”

I tried the steps with kernel version: 5.10.15-051015-generic but now OS is using the AMD Renoir as graphics driver.
nvidia-bug-report.log.gz (100.2 KB)

I apologies for the late replies. I was quite busy lately.

There’s no dkms build log for the 5.10 kernel, only for 5.11. Did you install the generic headers for 5.10? Please post the output of
dkms status.

dkms status was showing, I am not sure why I had build the 5.10 kernel :
hid-asus-rog, 1.0.2, 5.10.15-051015-generic, x86_64: built
hid-asus-rog, 1.0.2, 5.11.0-051100-generic, x86_64: installed
nvidia, 460.84, 5.11.0-051100-generic, x86_64: installed

but then I again ran the command:
sudo dpkg -i *.deb for 5.10 kernel

Now the new dkms status is:
hid-asus-rog, 1.0.2, 5.10.15-051015-generic, x86_64: installed
hid-asus-rog, 1.0.2, 5.11.0-051100-generic, x86_64: installed
nvidia, 460.84, 5.10.15-051015-generic, x86_64: installed
nvidia, 460.84, 5.11.0-051100-generic, x86_64: installed

I restarted the system and boom it worked. Now I am a happy man. After wasting around 2 weeks . My system is in place.

I really appreciate your help. Thanks a lot.
nvidia-bug-report.log.gz (327.4 KB)

Does the dkms module for the asus keyboard work fine?

Yes, Keyboard is also working fine as of now. I am not sure is it hid-asus-rog module or it would work fine without it in 5.10 kernel though. But now that power action issue is not there.

Thanks once again.

Hey, i have a similar Asus laptop and i have to work on ROS as well, which kernal version is your system finally using and which nvidia driver did you download? I installed linux kernel version 5.10.15-051015-generic and then while rebooting i get a black screen with this message:

/dev/nvme0n1p9: clean, 221670/11108352 files, 2568176/44428800 blocks
[ 2.2441331] nouveau 0000:01:00.0 unknownchipset (b76000a1)

fast boot and secure boot is disabled.