Out of the Box Jetson Nano Dev kit, not displaying Nvidia screen on powering up

Recently purchased a few Jetson Nano Dev kits. 2 of them were not displaying the Nvidia screen on powering up.

The modules from them were put on other Nano carrier boards, Nvidia screen doesn’t show up.
Other working modules were tested on these new carrier boards, they boot up as they are supposed to, displaying Nvidia screen on powering up.

Tried with and without SD cards in them.

In any case, the 2 new modules aren’t displaying Nvidia screen in any carrier board, but the 2 new carrier boards are able to boot up other Nano modules.

These dev kits are brand new, off the box. Our initial analysis is that the modules are defective. Appreciate any help or insight regarding this.

Edit:
Tried accessing Jetson via the serial debug console. You can refer the log file below:

Welcome to minicom 2.7.1

OPTIONS: I18n 
Compiled on Aug 13 2017, 15:25:34.
Port /dev/ttyUSB0, 13:29:14

Press CTRL-A Z for help on special keys

[0000.163] [L4T TegraBoot] (version 00.00.2018.01-l4t-e82258de)
[0000.168] Processing in cold boot mode Bootloader 2
[0000.173] A02 Bootrom Patch rev = 1023
[0000.177] Power-up reason: pmc por
[0000.180] No Battery Present
[0000.182] pmic max77620 reset reason
[0000.186] pmic max77620 NVERC : 0x40
[0000.189] RamCode = 0
[0000.191] Platform has DDR4 type RAM
[0000.195] max77620 disabling SD1 Remote Sense
[0000.199] Setting DDR voltage to 1125mv
[0000.203] Serial Number of Pmic Max77663: 0x150bec
[0000.211] Entering ramdump check
[0000.214] Get RamDumpCarveOut = 0x0
[0000.217] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.222] Last reboot was clean, booting normally!
[0000.227] Sdram initialization is successful 
[0000.231] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.237] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.242] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.248] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.254] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.260] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.266] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.272] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.288] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.294] Platform-DebugCarveout: 0
[0000.297] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.303] Non secure mode, and RB not enabled.
[0000.307] BoardID = 3448, SKU = 0x0
[0000.311] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.314] Nano-SD: checking PT table on QSPI ...
[0000.319] Read PT from (2:0)
[0000.334] Using BFS PT to query partitions 
[0000.338] PT: Partition TBC NOT found ! 
[0000.342] Warning: Find Partition via PT Failed
[0000.346] BoardID = 3448, SKU = 0x0
[0000.350] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.353] Nano-SD: checking PT table on QSPI ...
[0000.358] PT: Partition TBC NOT found ! 
[0000.361] Warning: Find Partition via PT Failed
[0000.366] Error is 1 

https://forums.developer.nvidia.com/t/debug-tips-when-you-hit-any-kind-of-system-issue-fail-to-boot-keep-reboot-etc/177457/2

@WayneWWW Thank you for the response. We have edited the post and added the log files.

We have seen such issue from other users too. The solution for this is to flash the board with sdkmanager.

Changing the sdcard version or use other sdcard won’t resovle this problem.

If you use the error log as keyword to search over the forum, you shall see I share the same solution for them.

Thank you Wayne, flashing the sdkmanager worked.

1 Like