Partially working stereoscopic effect with 3D vision under Debian linux

i have PMd the file

Hi 3dproblem, What 3d application you are testing with? Can you point the area where you are not seeing 3d effects? Also provide step-by-step bug reproduction steps.

We are tracking this issue under bug : 200295779 . We are still trying to reproduce it first with some 3d application.

this problem was across all 3d applications including GLXgears.

it has been solved: it seems the active displayport -> DVI adapter was introducing sync delay/error. i have tested with direct displayport cable and it is working perfectly now

thank you for your time.

Hi wpbgrenoble, Have you tried with direct displayport or DVI or HDMI cable ? I mean without any display dongle/adapter.

Indeed, the problem was due to the connection.

A direct DisplayPort (DP) - DisplayPort connection is absolutely required for correct operation.
The active adapters DisplayPort - DVI dual link were apparently not up to specifications and did not support the stereo correctly.

In addition, the HDMI input of the display did not have the bandwidth to support 3D.

The Benq 24" 144 Hz XL2411Z display works with an older Nvidia 3D graphics card using DVI output and the Quadro M4000 card absolutely required a direct DP connection.

It appears that the only monitor currently on the market seems to be the Asus VG248QE which allows to use 3D vision with a Quadro M4000 as it accepts DP.

It would be nice if Nvidia would update the list of 3D ready displays in particular the ones operating with DP input, as most of the references seem obsolete.

Best

Wim

Hi wpbgrenoble, Is it mean issue doesn’t reproduce when you use DP[gpu]<->DP[monitor] cable to connect monitor?

Exactly!

The Benq 24" 144 Hz XL2411Z display works with an older Nvidia 3D graphics card using DVI output
Do you mean with DVI<->DVI cable or DP<->DVI adapter? What was the old gpu?

The Benq 24" 144 Hz XL2411Z works with the Nvidia Quadro K4000 graphics card and a DVI-DVI cable.

So what is the issue then? Then this looks like adapter bug. If everything working fine with direct cable I’m closing this issue. Check with your GPU Vendor for recommended adapters.