Pascal. Bad performance when vulkan with vsync (VK_PRESENT_MODE_FIFO_KHR)

Desktop, card GTX 1050 TI.
I am using Ubuntu Mate. I tested ubuntu from 22.04 to 24.04, drivers from 535 to 550, in general nothing changes. Performance in games is low, especially visible in games on unity engine, in different games differently, somewhere the game frezes, somewhere fps jumps. At first I thought that the problem is in the window manager, but I tested and others, the problem does not go anywhere.

The game for example ‘Hollow Knight’, by default runs on api vulkan, just go into settings and enable vsync.

I tested the latest 555 drivers and the performance did not improve. I searched the internet and the problem is not only in Pascal but also in Turing. I recorded a video to give a better view of how horrible Vulkan’s performance is, this applies to both native games and via steam proton. I’m running the native Steam version.