People Pedestrian demo generate OCI Error on Jetpack 4.5

Hi,
I am complete newbie with this systems… please be kind with me.

I have tried to reinstall severall time my Jetson Nano 4GB with the release 4.5. Unfortunately, when I pull and then run the pedestrian error, the system report this error:

sudo docker run -it --rm --net=host --runtime nvidia -e DISPLAY=$DISPLAY -v /tmp/.X11-unix/:/tmp/.X11-unix nvcr.io/nvidia/deepstream-peopledetection:r32.4.2 deepstream-test5-app -c deepstream-5.0/samples/configs/deepstream-app/sourceX_1080p_dec_infer-resnet_tracker_tiled_display_int8_hq_dla_nx.txt
docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused “process_linux.go:449: container init caused “process_linux.go:432: running prestart hook 0 caused \“error running hook: exit status 1, stdout: , stderr: exec command: [/usr/bin/nvidia-container-cli --load-kmods configure --ldconfig=@/sbin/ldconfig.real --device=all --compute --compat32 --graphics --utility --video --display --pid=8279 /var/lib/docker/overlay2/53616a139e85803ca3fa95d16f60a77fd10a19ba4308134d5d9642fe64139b02/merged]\\nnvidia-container-cli: mount error: file creation failed: /var/lib/docker/overlay2/53616a139e85803ca3fa95d16f60a77fd10a19ba4308134d5d9642fe64139b02/merged/usr/lib/aarch64-linux-gnu/libnvidia-fatbinaryloader.so.440.18: file exists\\n\”””: unknown.

Version:
Linux poolpos 4.9.201-tegra #1 SMP PREEMPT Fri Jan 15 14:41:02 PST 2021 aarch64 aarch64 aarch64 GNU/Linux

Any idea?

Thank you
DS

Hi,

Since L4T docker mounts libraries from the Jetson itself, you need to use the same JetPack version as the container.
The image is built on rel-32.4.2, which is from JetPack 4.4DP.
Please reflash your system with JetPack4.4 DP to run the container.

You can find this information in the prerequisites on our NGC page:
https://ngc.nvidia.com/catalog/containers/nvidia:deepstream-peopledetection

Prerequisites

Ensure these prerequisites are available on your system:

  1. Jetson device running L4T r32.4.2

  2. JetPack 4.4 Developer Preview (DP)

If you prefer to use JetPack4.5, please use the repository below directly:

Thanks.

The repository you suggested can only pull container for r32.4.2

Hi,

Sorry that my comment seems not clear enough.
Please git clone the repository on the Jetson directly without using the container.

It should work on the libraries installed from the JetPack4.5.
The container cannot work since it also requires the L4T version to be the same.

Thanks.

Actually, this solution doesn’t work for me.

I’ve tried to flash my nx device using JetPack 4.4, and git cloned the repo in host pc , run the scripts, but no container can run the demo.

Also, I’ve tried to flash the JetPack 4.5, it failed again.