PGI Compiler Installation , pgcc: Command not found

I just received the license key these days and tried to install the PGI toolset, but failed.

I am a little bit confused about several things here.

I followed the installation guide step by step so I ran the installation script in the file. And when it come into “generate the license for this computer”, I answered “yes”, and provide my account id and password, and the generation failed .

I received the license key via email and has nothing to do with my current account. Is it the reason to fail ?

Except this, the installation went smoothly. I set the environment variable as said in the installation guide.
About the license, I simply create a “license.dat” file under the $PGI and copy the license key that I got.

I could use “pgcc -V” to see the version of the pgcc. However when I compiled some samples provided in the files, it indicate :

“pgcc: Command not found”

I am confused about the license key here and why the command not found ?

Can you help me to make it straight here ?



If the installation went properly, and you received keys in the mail.
Here is what to do with the keys, depending on the platform type.

On Linux, store as $PGI/license.dat,
and DO NOT start the license service (lmgrd.rc start).

On Windows, copy the temp license, as Administrator, to
C:\Program Files\PGI\license.dat and go to
Control Panel->Admin Tools-> Services and make sure
the PGI service is STOPPED.

On MAC, store as /opt/PGI/license.dat,
and DO NOT start the license service.

If you can’t find pgcc when running on Linux or OS X.

export PATH=./:$PGI/linux86-64/15.7/bin:$PATH

export PATH=./:$PATH
causes the current directory you are in to be searched first.