Pip3 python 3.5 not supported brakes tlt installer

It is now impossible to run this command
pip3 install nvidia-pyindex
pip3 install nvidia-tlt
python 3.5 no longer has pip and pip3 install nvidia-tlt does not want to run on other python versions.

DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality.
Defaulting to user installation because normal site-packages is not writeable
Looking in indexes: https://pypi.org/simple, https://pypi.ngc.nvidia.com
Collecting nvidia-tlt
.
.
ERROR: Package ‘nvidia-tlt’ requires a different Python: 3.5.2 not in ‘>=3.6.*’
Is there any alternative? Thanks.

See TLT Launcher — Transfer Learning Toolkit 3.0 documentation

Software Requirements

Software Version
python >=3.6.9

The tlt-launcher is strictly a python3 only package, capable of running on python 3.6.9 or 3.7.

1 Like

It works in ubuntu 18, Thanks