Pixelated, bad Alpha with artifacts in exr render Path Tracing


I’m getting a pixelated Alpha with some artifacts/ noise in the 2023.2 - 2023.4 as well as 2022.3. Rendering in Path-Tracing with motion blur in EXR with Alpha and HDR output on.

Have not used Omniverse for the last 5 month and had to rerender some frames - did not change anything in the render settings from before, but getting some weird alpha. Tried older versions - either same result or also getting black outlines around characters.

Basically it’s just animated characters in front of the HDRI (Dome Light) with primary visibility off.

Not sure what could cause it - would appreciate any help?

Here is how Alpha looks now vs how it looked before:

As you can see there is some noise with stripes all around the characters, no blur anymore, pixelated edges and some black outline between the characters and this weird noise:

New Alpha:

Old Alpha:

New Alpha:

Old Alpha:

Strange, can you package up your scene with the Collect Tool and send it to me in a PM ? Also can you try rendering to png and see if that is cleaner ? Try turning off Ray Reconstruction in the rendering settings. Make sure you have no other post processing options on.

Thank you for your reply!

I found that turning off Denoising in PathTacing Render Settings brings Alpha back to normal! Which is not ideal:(
Adjusting Optix Blend Factor or turning Denoise AOV off/ on still produces bad alpha as on screenshots above.

I’m trying it across different scenes, usd files from this project and get the same result. I’m not rendering any AOVs just in case.

Switching to png did not change the alpha. I can’t find the ray reconstruction option, where should it be? (running 4090 - driver 551.61; Omniverse - 2023.2.4)

*Updating driver to 551.76 did’t fix the issue

you can find it in your render setting > ray tracing section > NVIDIA DLSS rollout. below is from another thread where the OP had included screenshots of the location:

@Simplychenable Thanks! Oh I see it under Real-Time render settings, but not under Path-Tracing render settings with which Im rendering and having this Alpha issue - does Real-Time render settings for Ray Reconstruction affect the Path-Tracing rendering?

Edit: Disabling Ray Reconstruction in Real-Time settings did not affect my Alpha rendering in Path-Tracing. Still produces artifacts in Alpha with Denoise On.

i am not sure about Ray Reconstruction implementation in RTX - Interactive mode, but that option does appear to be absent after switching to pathtracing. i’ll defer to Richard.

1 Like

So it sounds like you are confirming that it is the denoiser for path tracing is “creating” noise in the alpha output ?

@Richard3D Yeah, it’s the only thing I found so far that’s causing it.

Thanks, we will take a look

1 Like