PlayBack a Captured Trace of an Application

How do I playback a captured trace in Nsight Visual Studio 4.1. I need to pause the playback trace in an interesting frame and profile that frame.

Hi shabby26,

That should be no difference as run other samples, just configure your Nsight User Settings, use Launch external program, make it point to your captured trace, also configure other settings as need. You should run the captured trace as expected.

Thanks
An

There should be a *.exe player to playback the captured traces right? Where is that file? Please elaborate! I am trying to capture frame by:

Open a dummy CUDA project
Go to Nsight Menu in Visual Studio 2013
Go to Start Performance Analysis
Use localhost as Connection Name
Add Application exe file path in Application
Add Application directory in working directory
Select Trace Application
Launch Application

Does the tracing work for DX 11 workloads?

Thanks

Hi,

When you referred to “playback a trace” I believe that An was thinking you were referring to a tool like apitrace.

Performance analysis is not an api-stream recorder like some of these other tools. Recording an API stream inherently has overhead; the purpose of Nsight’s performance analysis tool is to collect information in as low overhead a way as possible and so it does not attempt the task of recording an api stream. Instead, it collects runtime statistics in a low-overhead fashion as your application runs and presents them when you stop recording.

If you are working with DX11 and would like to capture a frame for debugging you should try the “Start Graphics Debugging” feature. Once run you can capture a frame via “Pause and Capture Frame”. Once captured, Nsight does have a source code serialization mechanism – click the save to disk button on the HUD that is draw over top of your application. This will generate source code for the frame that you captured and allow you to playback that frame in a way that is decoupled from your application.

Dan

Hi Dan

I was referring to a tool like API Trace only which can be record a trace file and play that back on Nsight to capture certain frames.

By the way, I am not able to launch a DX11 application (like 3dmark11) on Nsight. Is it not compatible?

Nsight doesn’t offer a tool to record and replay application traces. The closest capability is the source code serialization mechanism discussed above; it will serialize a singular frame.

To my knowledge there are no issues running 3dmark11 under Nsight. What issues are you encountering when you try to run it?

3DMark11 or 3DMark is not launching.

Go to Nsight -> Graphics Debugging
This does NOT LAUNCH 3DMark11 application. Same goes for 3DMark too. Only OpenGL apps are launching.
This command set works completely fine when used in cmd

Using:

Connection Name localhost
Application: C:\Program Files\Futuremark\3DMark11\x64\3DMark11Cmd[dot]exe
Arguments: --definition="C:\Program Files\Futuremark\3DMark11\bin\x64\custom_performance_definition[dot]xml
Working Directory: C:\Program Files\Futuremark\3DMark11\x64
Application is a launcher: Yes (tried No also)

Hi shabby26,

Seems you are using ‘Launch external program’ way, right? Maybe you can try to uncheck ‘Synchronize files’ under ‘Synchronization’. Retry, hope this can show some help.

Thanks
An

Does not work. Tried to remove synchronization. See the error screenshot.

Hi shabby26,

I am not sure, but are you trying to run a 64bit app on a 32bit OS? or maybe something else, I notice your Arguments: --definition=“C:\Program Files\Futuremark\3DMark11\bin\x64\custom_performance_definition[dot]xml, looks like you missing a '”’ at the end.

Please just try to ‘cd’ to ‘C:\Program Files\Futuremark\3DMark11\x64’, and run ‘3DMark11Cmd[dot]exe --definition=“C:\Program Files\Futuremark\3DMark11\bin\x64\custom_performance_definition[dot]xml”’ to make sure everything is already OK on your side.

Thanks
An

The OS is 64 bit. I am sorry I did not put " in the end. When I am trying to run the same thing on Command Line, the application launches correctly. Only it’s not launching on Nsight

Hi,

That’s weird, I need more detail to investigate:

  • could you share us your 3DMark11?
  • I need the information about your PC
    • Driver version
    • OS version
    • GPU
  • your Nsight version
  • Could you send your screen shot about configuration to us and how your steps to meet the issue.

Thanks
An

By the way, OpenGL workloads like GfxBench etc are working correctly. DX workloads like 3DMark/3DMark11/Vantage are not working. The information:

  • could you share us your 3DMark11? Product Version: 1.0.132.0
  • Driver version: nvlddmkm 9.18.13.4416(ForceWare 344.16)
  • OS version: Win 8.1 64 bit
  • GPU: NVIDIA GeForce GTX 970, GM 204
  • your Nsight version: Visual Studio Edition 4.1

Moreover, I am also not able to make a host-server connection via ethernet. I attached the issue screenshot before. (issue6[dot]jpg)

Hi shabby26,

I think I found the root:

  • 3DMark11.exe and 3DMark11Cmd[dot]exe are all .Net App, which is not support by Nsight

Since it’s not Win32 app, that make Nsight prompt the error. I think this will also explain the question in your another post/thread.

Thanks
An

So does that mean that I just cannot analyze a 3DMark11 or 3DMark in Nsight. :(

I downloaded the latest Nsight and Display Driver. I also have the latest Nsight version, that is 4.1.0.14255

Hi shabby26,

I am sorry about that, Nsight only support native code officially.

Thanks
An