Playing audio files on Jetson TX1 through USB

Hi all,
I want to listen audio out through USB speakers . Currently I am using sox for playing the audio file on TX1. I found out that it takes default route through HDMI . Is there any way to play that file via USB speakers ? I’m using iBall USB speakers. What software / pkgs i need to install for this ? What settings do i need to do for this ?

Thanks in Advance.

You may find having some test files useful. Here is what I use (specifically, the mp4 version…the sound is amazing):
http://forum-movies.com/view/dolby-digital-plus-7.1-speaker-test/-TdLTe_yckY

If you install something like mplayer or xine, naming this file as an argument should play correctly for the number of channels you have (I’m using 7.1 Surround Sound headphones).

I find all audio sometimes frustrating, as mixer settings are often just a jumble of devices and parameters with absolutely no intuitive naming…a LOT of trial (and mostly) error to get it right. I find that often any app which has a pulse-audio front end tends to set things up for me, whether I use that program or not. One of my first audio tests on the JTX1 was to install the “mumble” voice chat software and make sure it could see and use both USB headset speakers and microphone. Once I do this, other things typically work. This also means that although you won’t necessarily know why one part of audio setup in the mixer has a given setting or not, you can now dump the audio mixer settings and use that for a baseline in future audio setup.

Does this file play correct with any of your video apps?

Hi , Thanks the valuable inputs. The issue is resolved now. I switched the audio out through Digital instead of analog. So its playing through USB speakers . This setting is given in the OS itself in Sound Settings. Now its playing both audio and video .

Hello Aditya
How did you extract sound to speakers, without jack use? i2s ?
Need help please !!

my request is here :
https://devtalk.nvidia.com/default/topic/949616/jetson-tx1/setting-audio_mclk-to-output/post/5087521/?offset=15#5087525

Thanks, friend
Vincent

Hello Vincent,
I used USB speakers to play audio files. I used the default sound settings provided in the OS.

Hi, Aditya

Will you please tell me how you settig in the OS? I also want to get sound from USB! I have installed VLC media player, but I can not get sound from a usb sourd card inserted into the USB of TX1.

If you replay with your setting, I’ll be very gratefully!!

I have got sound from VLC media player, and set Tools/Preferences/Audio Settings, Output model: alsa audio output, device: USB Audio Device, USB Audio default audio device.