[Possible Bug] Changing render modes cause vram memory leak


In the latest Create beta; for me…changing render modes seems to cause a vram memory leak. This eventually
crashes Create.

Windows 11 PRO ( 22H2- 22621.1194)
TR 3970x - ROG Zenith II Extreme ALPHA
Create Beta 2022.3.1 / STUDIO Drivers 528.24

Hi Silhyon.
I see that your memory display line turns RED for the primary card. However, this is not really a memory leak as such. By changing rendering modes, we are allocating more and more GPU buffer memory, but it will all be used as required when loading a scene. The RED seems like a critical error but it will clear and stabilize once you start working with a scene as normal.

If it is actually crashing, then that is something else we have to take a look at. One tip is that Realtime and Interactive share the same memory pool. Accurate is a completely different renderer and requires a complete copy and rebuild of textures and therefore memory. Unless you plan to use Accurate, I would not load it in.

Hi Richard_3D,

Thanks for the information; Its helpful…unfortunately, Create is crashing as the VRAM is not recovering in time as I switch modes (Note: GPU Timeout is set higher then normal). By your reply I am assuming you can turn off accurate via an extension? I only ask because I switch into the mode by accident when I discovered this.

I will create a shareable scene today and see if the issue is still happening.

No you cannot turn off Accurate. It is core. I would just try to work without initializing Accurate at all. See how far you can go without a crash, and not going to Accurate. It should not crash obviously, but let’s see how stable you are just sticking to the first two modes. If you keep crashing, then please send me your logs.