Possible bug in sequencer when reversing an animation


I try to compose an animation of different clips and some of those clips should play reverse.

In this video tutorial it looks like this is possible, but I cannot reproduce that behavior in the latest usd composer versions: (1164) How to loop, reverse, and offset animations in Nvidia Omniverse Create with Animation Sequencer - YouTube

Is this a bug? Or how can I achieve this?

Example of what I would like to achieve:

  1. Play frames 0-80
  2. Play frames 80-50
  3. Play frames 50-100



Ok I will try to repro. In the meantime either manually reverse the keyframes or render out the sequence as normal and reverse it in your comp app.

Sorry, I forgot to mention that I want to animate a Skeletonanimation in this case… so no key frames. Reversing the rendered frames is not an option, because I have more than one skeleton animation I have to control and the animation clips of those animated assets could overlap each other.

As far as I know reversing is just for keyframes. If it’s imported skeletal animation you are better off doing that is the raw source.

Hmm… that’s a problem… at the end I don’t know why that should not be possible.

Anyway, I saw that the animation clips one can create inside of an animation graph have a “reverse” flag (but I wasn’t able to figure out how to use those animation graphs for my purpose) would that do the trick?