Camera usd import in sequencer seems odd

Hi, I created a couple of cameras in houdini and export them with the omniusdexport, camera2 has animation from frames 1-700 and camera3 400-1000, everything seems to be ok when I reference the usd on create, but when I add them to the sequencer things get really funky, maybe I just don’t understand how really wokrs, I added both cameras, camera2 for the first 400frames and then camera3, but the animation on camera3 seems to have some offset, and sometimes the camera2 the movement just stops like about frame 200, can someone help understand how this clips work. To me they seem like windows that allows you to see a segment of the animation while they are on, and unless I change the offset property I’m just choosing what segment of the animation is visible, am I right? because when I try to slide them as if they were a maya clip or a video clip they animation seems to stay linked to the frames not to the clip (367.0 KB)
gioFi_04_03.cameraSequencer.usd (2.7 KB)

Hello @maxmax003! Thanks for letting us know about this. We want to make Omniverse as streamlined as possible, and it sounds like this was not the case for you. I am sending this information over to the dev team now.

Just curious, did you try adding your camera’s in the Omniverse App Machinima’s Sequencer? If so, did you get the same results?


First thing is to look at each clip’s properties:


The first section Sequence Clip are the time values in the parent reference time - i.e. the time in the USD stage. So this clip starts from 400 and ends at 994 and plays at rate of 1.0

The second section Source Animation specifies what frame range to sample from the source data - in this case your camera’s animation values. nan means it’s not specified - so sequencer will sample the full range of the source.

When I add your cameras to sequencer tracks - it appears that each camera has animation from 0-999 (camera2 has flat curves after 700, and camera3 has flat curves until frame 400).

Sequencer cannot know what frames are relevant, so one thing that might help is to only export the animated range of your assets in the future. Then you can easily drop them into sequencer to retime without having to trim.

So what’s happening in your second clip is that you have offset your animation in the stage time, but you haven’t trimmed the values from which it is sampling the source animation. So the clip for camera3 is starting at 400 - but at frame 400 it’s sampling frame 1 of that camera’s animation. I hope that makes sense.

The simplest thing to do with this data is to use two tracks:

The top-most shot track will be the active shot until frame 400 and then it switches to camera3.

Otherwise you need to trim your second clip. For that, the Source Animation in and out values cannot be nan: that appears to be a bug. When you create a new clip those values should be set so you can effectively trim. I will look into this issue.

But you can manually set the values:

These values mean that at time 400 of your stage, it will be sampling the source animation’s frame 400 and looks like this:

Hi, thanks for your quick response, @WendyGram I did not tried machinima, to be honest not sure what the differences are beyond machinima having character stuff, I’m just trying stuff with some object animated from houdini. Also I find animating cameras in create a bit conversome, sometimes they jump when I try to add a keyframe and the curve editor is a bit weird, I think you should try to replacte maya’s timegraph, so far is the best(I have used a lot of 3d packages).

@agrant3d thanks for the explanation, I didn’t knew what the nan was about and I tried setting it up to my frame animation range, but I was not sure what was going on, I’ll try to follow your instrucions, I exported the hole range because I didn’t want to export the cameras one by one. I think I kind of see what you mean about having the first 400 frames as flat curves, but I wasn’t able to trim it, is that the blue handle in the middle of the clips isn’t it? so I trimeed it to frame 400 and the slide the clip to frame 0, but it seem like I was still looking at the flat part, I’ll try setting up the source animation first, anyway, I think I should try with this information to se if I can make it work

Yes, the blue handle is supposed to trim. But trimming must have values in the Source Animation In/Out values for it to work. I’ll look into why dropping these cameras into sequencer are not initializing the source values.

1 Like