Powering Jetson Nano and T100 shield though DC-DC converter via barrel jack

Hi all,

I have 2 Jetson Nanos here, with the T100 shield from Geekworm (this thing: https://geekworm.com/collections/nvidia/products/nvidia-jetson-nano-nvme-m-2-ssd-shield-t100-v1-1) and I’m struggling to power them.

I need to use the Jetson Nano in an embedded application that prevents me from using the provided power supply, and the only power line available to me is 12V 3A. For this reason I have procured a TracoPower THN 15-1211 DC DC converter (https://nl.rs-online.com/web/p/products/438272?cm_mmc=NL-PPC-DS3A--google--3_NL_NL_M_A_and_C_BMM--tracopower%7Cisolated_dc_dc_converters--%2Bthn+%2B15+%2B1211&matchtype=b&kwd-157446001735&gclid=CjwKCAiA3OzvBRBXEiwALNKDP2LHESEmwgIquHDnXLF0O-T1HkJpGaBIGulvAan2imf8ls5KZNQNahoCdlMQAvD_BwE&gclsrc=aw.ds) which is capable of delivering 5V at 3A (15W)
The converter works great, as I have tested it on some simple circuitry, but when I try to power my Jetson Nanos with them, the Nano doesn’t complete the boot. I have a screen connected to it and I see the Nvidia logo on screen for a few seconds and then the boot stops.
My Jetson boards work without issues when powered with their normal wall-adapter power supply.

Would you have any idea why I cannot boot the Nano with a 5V3A supply? Note that I can adjust the output voltage of my converter, and I’ve already tried with a 5.35 output and it still behaves the same.
I’d be happy to receive any suggestion.

Thanks,
Nicolas.

I have the same board and 3A is just not enough to power both the Nano and the T100. Are you using the “Y” cable or are you powering the T100 via the short USB3 cable? You could use 2 converters, 1 supplying the Nano and the other supplying the T100. Just make sure they have their grounds tied together.

Oh yeah, also check out this thread for more info on the T100…
https://devtalk.nvidia.com/default/topic/1066735/jetson-nano/anyone-got-the-geekworm-jetson-nano-nvme-m-2-ssd-shield-t100-working-reliably-/1

Hi,

Thanks for your help. The T100 was powered using the Y-barrel jack cable. I have just tried now powering the Jetson nano without the T100 and I have the same issue. It looks like the Jetson nano on its own draws some inrush currents higher than 3A during boot.

I’ve contacted the supplier of my DC-DC converter and they confirmed that computers tend to require quite a lot of power during boot and inrush currents during this phase can be a problem.
I probably need to get some 20 or 30W converters instead of 15W as I have now.

Thanks for the extra info. I’ve be very curious to try and measure the inrush properly, with a good oscilloscope and some current probes.

Hi,

Sorry to revive this topic, but I still haven’t solved my problem and I now have new information.

The following concerns the Jetson Nano without the T100 board from Geekworm:

My Jetson Nano boots perfectly fine using the power adapter sold by Geekworm through the barrel jack. However, when powering the Jetson Nano though a simple DC-DC converter, the boot starts and stops after something like 10 seconds (I can see the Nvidia logo on screen but not more).
I have tried these 2 DC-DC converters, from the 2 different brands:

  • TracoPower THN 15-1211 (datasheet here: https://www.mouser.be/datasheet/2/687/thn15-519374.pdf )
  • Murata UEI15-050-Q12P-C (datasheet here: https://www.mouser.be/datasheet/2/281/mdc_uei-15w-180216.pdf )

Now, both of these are 15W DC-DC converters, and should in theory be able to power the Jetson Nano correctly. Both have been tested on other circuitry, and can for instance power Raspberry pis at full power draw without any issue. But still, impossible to boot the Jetson Nano.

Suspecting some inrush current at startup, I went on and powered the Jetson Nano through a lab power supply rated for 60V 10A (with banana plugs connected to a DC barrel jack, and there I managed to boot the Jetson Nano, with 5.0V and a current limit of 1.3A on the power supply. So it seems that the Nano can boot without drawing that much current after all.

This really puzzles me. Why can’t I get the Jetson Nano to boot when powered through a COTS DC-DC converter? It is starting to become a real issue for my embedded application (which only has a 12V line available). What in the characteristics of those converters is not OK for the Nano? Could it be the startup time? The switching frequency? I’m struggling to understand where the problem comes from.

Note that I should receive soon some other converters rated for 25W and 30W and I will repeat my tests, but I don’t have much hope at this point.
Could anyone from Nvidia give me some pointers?
Thanks a lot!

Hi, did you use oscilloscope to observe if any voltage drop during power on with DC-DC? What’s the real input voltage on board side? Did you try shorter cable to decrease Rs? And what’s the result with 25W/30W converter?

When you limit the current to 1.3A, you attempt to draw more than 1.3A from your lab power supply, how long does it take for the voltage to drop? If it takes too long, the voltage might not actually drop low enough to shutdown your Jetson Nano. This is why Trumany is suggesting you use an oscilloscope to see if the voltage is actually dropping during boot up. Maybe your lab power supply contains large capacitors on the output and your DC-DC converters don’t. And maybe you could solve this issue by installing a large capacitor between your DC-DC converters and your Jetson Nanos.