Problem during initial installation of Linux on laptop with Nvidia adapter

Good morning.
I am trying to install Kali Linux 2018.1 64 bit on an Acer Aspire V15 Nitro which has an Nvidia GP106 graphics adapter.
Live install boots fine from a CD or a USB stick but trying a permanent installation on the hard disk always ends in a black screen after starting any of the installation options (graphics, advanced, text, etc.).

For several weeks I have tried all recommendations from numerous FAQs, forums, etc. with no solution.
I have tried different boot command line options like:

nouveau.modeset=1
nouveau.modeset=2
i915.modeset=1
i915.modeset=2
(quite was eliminated)

And obviously impossible ones (as Nvidia does not support VGA modes)

nomodeset
vga=ask
(different resolutions were tried)

The last three were hopeless, I know, but I am losing hope. No solution published anywhere worked until now.

Does anyone know working command line options?

I could post the dmesg from the live installation but I do not want to clog up the forum if someone has an answer at hand.

Any help will be appreciated greatly.

Audoghast

Blacklist nouveau, then follow this:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

Thank you for the quick reply.

Unfortunately, this does not work because I am at the initial stage of installing linux.

The only parameters I can change are the kernel parameters and the preset is:

/install/gtk/vmlinuz video=vesa:ywrap,mtrr vga=788 quiet net.ifnames=0

I have tried this:

/install/gtk/vmlinuz nouveau.modeset=0 nvidia.modeset=1

And also:

/install/gtk/vmlinuz nouveau.modeset=0 nvidia-drm.modeset=1

By the way, when I run the live install it does use the nouveau driver, but I want to permanently install it on my harddisk.

Thanks for any further suggestions.

Audoghast

I don’t really know what the exact problem is.
Please post the output of
sudo lspci

The lspci is only accesible when I run the live install from the USB stick and here it is:

root@kali:~# lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060] (rev a1)
02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

When I try to install it permanently to the harddisk I get a black screen without contents overlapping the original install menu screen.
I have also tried to attach external devices via HDMI but HDMI is not available this early during the boot stage.

As it runs during live install it is compatible to my hardware. I just do not know the correct command line parameters (and the preset ones from my earlier post do not work).

Thank you again for your help and input.

Audoghast

IMG_4411 (Small).JPG

IMG_4412 (Small).JPG

Like said, that’s an Optimus laptop, i.e. the display is connected to the intel gpu. So during live environment and during install, the nvidia is inactive. It has to be enabled with the aforementioned procedure later on.
So the installation hanging is most likely completely unrelated to the nvidia gpu. Doesn’t Kali has a text mode installer? Maybe in advanced options?

Kali has text mode installers and several advanced options but all of these result in the same picture.

A black screen covering 3/4 of the screen (you can still see the original menu peeking through on the left) and no reaction to anything. So even the text mode needs something from the graphics card that I cannot set at this stage.
Kali even has a voice installer mode but it is a hardcore robotic voice speaking super fast and there is no way to understand anything it says.

I believe the only option for me is to take out the harddisk, put it in some other hardware, install it there and then put it back in the original laptop. Not really a convenient method.

Thanks for all your input. If I try what I said I will post the results.

Audoghast

use this:

for-> “Kali Graphical Install” press e and add efi on both line that’s all: and remove rest

linuxefi /install/gtk/vmlinuz video=vesa:ywrap,mtrr vga=788
initrdefi /install/gtk/initrd.gz

this will work fine.
Best of luck!