Problem in Creating Development Environment for Cuda using Nsight

I am trying to compile 3_Imaging, the DecodeGL program on my Host Machine( 64 bit Ubuntu 14.04 Kernel 3.19.25 Generic), for TK1 and I am getting this error :

/usr/local/cuda-6.5/bin/nvcc --cudart static -L/usr/local/cuda-6.5/samples/common/lib/linux/armv7l -L/usr/arm-linux-gnueabihf/lib -L/usr/lib32/nvidia-352 -L/usr/lib/nvidia-352 -lGL -lGLU -lglut --relocatable-device-code=false -gencode arch=compute_30,code=compute_30 -gencode arch=compute_32,code=sm_32 -m32 -ccbin arm-linux-gnueabihf-g++ -link -o “sample_imaging_cuda” ./src/FrameQueue.o ./src/ImageGL.o ./src/NV12ToARGB_drvapi.o ./src/VideoDecoder.o ./src/VideoParser.o ./src/VideoSource.o ./src/cudaModuleMgr.o ./src/cudaProcessFrame.o ./src/videoDecodeGL.o /usr/local/cuda-6.5/samples/common/lib/linux/armv7l/libGLEW.a -lcuda -lnvcuvid -lcudart
/usr/bin/ld: cannot find -lnvcuvid
make: Leaving directory `/home/ubuntu/sample_imaging_cuda/Debug’
collect2: error: ld returned 1 exit status
make: *** [sample_imaging_cuda] Error 1

I have tried the hook mentioned in Release Notes but still the same issue is there.It happened once eventually the error was not there, but, after a reboot of TK1 the problem persists.

Kindly help.


Rajarshi Haldar