Problem in loading USD to Isaac sim simulation

When I use USD from nucleus server it works fine and it is imported but when I download the same usd and give its path to my python script it does not load.

Also the downloaded file is not loaded by isaac sim through the user interface.
I tried using the full_warehouse.usd for this. But I had faced similar issue for transporter.usd.

Kindly let me know how can I use the downloaded USDs for the simulation. Or how can change the usd at nucleus server.

Hi. The USD file may contain references to other files like materials. Downloading just the full_warehouse.usd may not work.

I would suggest copying the entire /NVIDIA/Assets/Isaac/2022.2.0/Isaac/ folder to /Isaac. So that the relative paths to /NVIDIA and other folders is still the same.

Next, use the get_assets_root_path() function to retrieve this new path in your Python script. E.g.:

   from omni.isaac.core.utils.nucleus import get_assets_root_path
   scene_path = "/Isaac/Environments/Simple_Warehouse/full_warehouse.usd"
    assets_root_path = get_assets_root_path()
    if assets_root_path is None:
        carb.log_error("Could not find Isaac Sim assets folder")
    # load scene
    (result, error) = await open_stage_async(assets_root_path + scene_path)

To set the new path, run Isaac Sim with this flag:

This method will make the /Isaac folder editable but the /NVIDIA folder is still read-only.

1 Like

Got it thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.