Unable to import omni.kit.asset_converter

I’m attempting to utilize the code from here to convert some files to usd. However, when attempting to run the script, I get the error ModuleNotFoundError: No module named 'omni.kit.asset_converter'. Has it been moved to somewhere else in the API structure since the documentation was created, is there another problem?

Have you tried to import through the UI (file->import)

I have not; I’m working through the command line by launching an isaac-sim container then running the script inside of it via the associated python environment. Is this something I need to use a GUI for?

Hi @ian.oneill

Do you import the module after the SimulationApp helper is loaded?

https://docs.omniverse.nvidia.com/app_isaacsim/app_isaacsim/manual_standalone_python.html?#simulationapp

I was not, and I think that’s likely what the problem was. However, I then found that there was already a complete and working script for this under /isaac-sim/standalone_examples/api/omni.kit.asset_converter/ that works for what I needed to do. The simulation app being loaded is part of the main function there. However, the actual converter function is way more robust as well, so I’m not sure what’s up with that discrepancy.

thanks for pointing that out @ian.oneill
The first snippet is meant to be run in a script editor when using isaac-sim.sh (which is why its async) and is more for illustrative purposes

The second sample you mentioned is more robust and meant for scripted asset conversion. Let me see if there is a way to make this clearer, or possibly remove that first snippet.

Can I mark this issue as solved, with the recommendation being to use that standalone_example script?

Yes, thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.