Unable to import NVIDIA usds

when I launch the simulation with OmniKitHelper (for example by python.sh python_samples/simple/load_stage.py) all works fine. I can import simple USD (like the carter and others) but when I try to import the Orc/any other USD asset from the NVIDIA package Isaac freeze unexpectedly without any error.
I tried also to download the Orc, for example, in my pc and try that path but that does not work either. Am I by any chance running an “incomplete” Isaac in those examples?

Related to this: is there a way to launch isaac-sim with all the components as when it’s launched from omniverse through python?

The first question, can you provide the path to the Orc asset on the NVIDIA mount? I want to make sure I am reproducing/testing your issue with the correct asset

The second question:
you can copy dependencies from the top of apps/omni.isaac.sim.base.kit into apps/omni.isaac.sim.python.kit anything added to this file will load by default when the python app starts. You can make additional .kit files for specific usecases as well and pass them as part of the omnikithelper config

The main one the python version needs is "omni.kit.loop-isaac" = {} because that allows the update timestep to be controlled. The rest can all be the same as the base app.

The path is omniverse://localhost/NVIDIA/Assets/Characters/Reallusion/Orc/

I tried to create a scene with the Orc already in it and that works (mesh, animation and everything).

I tried to clean everything and restart and the import worked ONCE (i.e. the simulation did not freeze and the asset was loaded in the scene) but in that case the animation wasn’t working (problems with paths perhaps). After that, every time I try to repeat the procedure Isaac freeze.

I’m following ECMR this week I’ll try your suggestion first thing when I have time ;) thanks!