Problem Tearing with NVIDIA + Linux + Lightdm + Openbox

Hello everyone,

I have a pretty annoying problem with nvidia. I went through the NVIDIA support which redirected me to this forum.

I’m on Ubuntu 14.04 with Openbox, the NVIDIA driver version is 331.38, the graphics card is a GT630.

Under Openbox when I read a video with either Chrome or VLC, I have tearing.

If I reinstalled ubuntu with gnome3 or ubuntu-desktop (unity), I have no tearing.

I’ve tested all Nvidia drivers (331.67, 334, 337 beta) but still the same problem.

I tried to disable the composite in the xorg disable backing store in lightdm, but nothing works.

Someone would have a solution to remove tearing in openbox?

Thank you very much.

PS: Sorry for my English

Heyyo,

I remember it had something to do with the way nVidia handles vblank with newer drivers… I know reverting back to older drivers does fix the issue.

Here’s a more detailed thread with the exact same issue you’re observing:
https://devtalk.nvidia.com/default/topic/543305/screen-video-tearing-gtx6xx-7xx-titan-kepler-maxwell-in-almost-all-applications-including-desktop/

languille11, Any old driver worked for you ?

Hi, I’m using lubuntu 14.04 . Since LXDE based off Openbox, you might want to refer to this link http://ubuntuforums.org/showthread.php?t=2144468 .

I feel all of your pain here. I am using BunsenLabs buster Lithium and having a hell of a time figuring out how to fix this issue. I am not quite sure reverting to an older revision of the nvidia drivers is the greatest thing to do as if you use nvidia-settings tool and go to advanced tab and select force composition pipeline on each of your displays it fixes the tearing issue. My problem here is I cant figure out how to create a xorg.conf that the “Save to X Configuration File” button wants to save to using lightdm and existing stock display manager.