Problem to grab image

hi

I am developing my own mipi camera module. In the trace log, I got

 kworker/0:2-1582  [000] ....    81.228748: rtcpu_nvcsi_intr: tstamp:2957209221 class:GLOBAL type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000004
 kworker/0:2-1582  [000] ....    81.228749: rtcpu_nvcsi_intr: tstamp:2957209221 class:CORRECTABLE_ERR type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000004

Referred from other topics, I have apply “Boost clock” from Jetson/l4t/Camera BringUp - eLinux.org

Follow instructions in How to disable ECC check
but I still get CRC error
kworker/0:2-1582 [000] … 81.170471: rtcpu_vinotify_error: tstamp:2956898506 tag:CSIMUX_FRAME channel:0x00 frame:1 vi_tstamp:2956896931 data:0x00400060

Here is a short summary from log

    v4l2-ctl-8813  [002] ....    81.096223: tegra_channel_capture_setup: vnc_id 0 W 1440 H 720 fmt c4

 kworker/0:2-1582  [000] ....    81.168661: rtcpu_vinotify_error: tstamp:2955572228 tag:CSIMUX_STREAM channel:0x00 frame:0 vi_tstamp:2955570740 data:0x00000001
 kworker/0:2-1582  [000] ....    81.168763: rtcpu_vinotify_event: tstamp:2955647894 tag:CSIMUX_STREAM channel:0x00 frame:0 vi_tstamp:2955570740 data:0x00000001

 kworker/0:2-1582  [000] ....    81.169209: rtcpu_vinotify_event: tstamp:2955986456 tag:FS channel:0x00 frame:1 vi_tstamp:2955958813 data:0x00000010
 kworker/0:2-1582  [000] ....    81.169211: rtcpu_vinotify_event: tstamp:2955987199 tag:ATOMP_FS channel:0x00 frame:1 vi_tstamp:2955958814 data:0x00000000
 kworker/0:2-1582  [000] ....    81.169212: rtcpu_vinotify_event: tstamp:2955987364 tag:CHANSEL_PXL_SOF channel:0x23 frame:1 vi_tstamp:2955965134 data:0x00000001
 kworker/0:2-1582  [000] ....    81.169844: rtcpu_vinotify_error: tstamp:2956422980 tag:CSIMUX_FRAME channel:0x00 frame:1 vi_tstamp:2956421349 data:0x00400060
 kworker/0:2-1582  [000] ....    81.169845: rtcpu_vinotify_event: tstamp:2956423415 tag:CHANSEL_PXL_EOF channel:0x23 frame:1 vi_tstamp:2956419590 data:0x02cf0002
 kworker/0:2-1582  [000] ....    81.169846: rtcpu_vinotify_event: tstamp:2956423558 tag:ATOMP_FRAME_DONE channel:0x23 frame:1 vi_tstamp:2956419610 data:0x00000000
 kworker/0:2-1582  [000] ....    81.169848: rtcpu_vinotify_event: tstamp:2956423855 tag:CSIMUX_FRAME channel:0x00 frame:1 vi_tstamp:2956421349 data:0x00400060
 kworker/0:2-1582  [000] ....    81.169849: rtcpu_vinotify_event: tstamp:2956424013 tag:ATOMP_FE channel:0x00 frame:1 vi_tstamp:2956421349 data:0x00000000

It looks like driver can get whole frame data, but not sure why it can’t transfer data in?

Please help advise,

thanks,

hal.

trace-20220217.log (13.1 MB)
attached full trace log.

What’s the version?
Also check below for J4.5/J4.6.1

J4.3

hi ShaneCCC,

Thanks for looking into this. After fixing the hardware, it is working now.

hal

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.