Problem with GPIO headers in Carrier Board Jetson TX1

I have Jetson TX1 Connect Tech Carrier Board.
when I want to import the board library in python it shown this error:

WARNING: Carrier board is not from a Jetson Developer Kit.
WARNNIG: Jetson.GPIO library has not been verified with this carrier board,
WARNING: and in fact is unlikely to work correctly.
Traceback (most recent call last):
  File "", line 1, in <module>
    import board
  File "/usr/local/lib/python3.6/dist-packages/", line 136, in <module>
    from adafruit_blinka.board.nvidia.jetson_tx1 import *
  File "/usr/local/lib/python3.6/dist-packages/adafruit_blinka/board/nvidia/", line 3, in <module>
    from adafruit_blinka.microcontroller.tegra.t210 import pin
  File "/usr/local/lib/python3.6/dist-packages/adafruit_blinka/microcontroller/tegra/t210/", line 4, in <module>
    import Jetson.GPIO as GPIO
  File "/usr/lib/python3/dist-packages/Jetson/GPIO/", line 1, in <module>
    from .gpio import *
  File "/usr/lib/python3/dist-packages/Jetson/GPIO/", line 70, in <module>
    model, JETSON_INFO, _channel_data_by_mode = gpio_pin_data.get_data()
  File "/usr/lib/python3/dist-packages/Jetson/GPIO/", line 463, in get_data
    for fn in os.listdir(gpio_chip_gpio_dir):
FileNotFoundError: [Errno 2] No such file or directory: '/sys/devices/7000c400.i2c/i2c-1/1-0074/gpio'

what can I do ?
this seems have problem to connecting to the GPIO headers…
anyone can help me ?

must be a problem with GPIO pin configuration because I ran the same problem previously on this board and it works fine without any problem…
is there any library shoud I install for working with gpio pins ?
also when I want to send serial data from board with pins in python, it gives me the same error…
what is the problem exactly ???

Hi Hamzeh.nv,

What’s your Jetpack version in use?

Could you share the result of the following command on your board?

$ ls -l /sys/devices/7000c400.i2c/i2c-1/

What’s your modification for GPIO configurations before it doesn’t work?

Hi, Thank you for your response
My Jetpack Version is 4.6.4
this is the result of the command that you say:

total 0
drwxr-xr-x 3 root root    0 Mar  2  2023 1-0042
drwxr-xr-x 3 root root    0 Mar  2  2023 1-0043
drwxr-xr-x 3 root root    0 Mar  2  2023 1-0074
drwxr-xr-x 3 root root    0 Mar  2  2023 1-0077
-rw-r--r-- 1 root root 4096 Oct  3 10:00 bus_clk_rate
--w------- 1 root root 4096 Oct  3 10:00 delete_device
lrwxrwxrwx 1 root root    0 Oct  3 10:00 device -> ../../7000c400.i2c
drwxr-xr-x 3 root root    0 Mar  2  2023 i2c-dev
-r--r--r-- 1 root root 4096 Oct  1 06:39 name
--w------- 1 root root 4096 Oct  3 10:00 new_device
lrwxrwxrwx 1 root root    0 Oct  3 10:00 of_node -> ../../../firmware/devicetree/base/i2c@7000c400
drwxr-xr-x 2 root root    0 Oct  3 10:00 power
lrwxrwxrwx 1 root root    0 Mar  2  2023 subsystem -> ../../../bus/i2c
-rw-r--r-- 1 root root 4096 Mar  2  2023 uevent

I don’t do any configuration for GPIO.
just when I import the board or Jetson.GPIO library in python I get this error…

Is this problem related to the Jetpack version?

You said it could work before?

Do you mean it could work with older Jetpack version before?

yes It works fine with JetPack 4.6.3
but, do you think this problem depends on the Jetpack version?
are sure?

There should not be too much difference in these two release.
It may be caused from some permission issue.
Please let me check with internal.

thank you so much Kevin

Did you run the command with sudo?

The error message says that your code looks for an I2C device (an GPIO expander?) on bus i2c-1 and I2C address 0x74 and doesn’t find one. Is this specific hardware present? Does i2cdetect find it?

yes I tried with the sudo command and doesn’t work anyway

when I run the i2cdetect -y -r 1 command
it finds the 0x76 address not 0x74 address.
but the i2cdetect command works properly with no problem
and note that. I’m using the Jetson TX1 carrier board

Could you share the result of the following commands on your board?

$ cat /etc/nv_tegra_release
$ cat /etc/nv_boot_control.conf

$ i2cdetect -y 0
$ i2cdetect -y 1
$ i2cdetect -y 2

We could not reproduce the issue on the TX1 devkit with JP4.6.4.

From the release page of ConnectTech, it seems the latest release for TX1 is JP4.4.
How do you use JP4.6.3 and JP4.6.4 with TX1 on Connect Tech carrier board?

1 Like

I don’t know.
the Nvidia sdk-manager told me jetpack 4.6.3 was available for the board and then I installed it.
you are right, I have to reinstall the jetpack and change the version to 4.4
thank you so much for your help.

The BSP package from SDKM is used for the devkit only.
You should download the custom BSP of JP4.4 from your vendor’s website for your custom carrier board.

thank you for your help @KevinFFF
if there is any problem in the future, I will be thankful to help me.🌸
have a good time 🌸❤

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.