Problem with Nvidia driver 435.21 0ubuntu0 18.04.2 ...Driver not detected; indicates as N/A

I am having a problem with the Nvidia driver 435.21 for 0ubuntu0 18.04.2 for Linux Mint 19.3 Cinnamon Verstion 4.4.8. I am trying to use my external NEC monitor with the HDMI connection. When I look at the Graphics information in Terminal mode the driver reads as: N/A for my Nvida graphics card. I have downloaded and installed the new driver, as is the recommended metapackage.

–Graphics Card: GM107M (GeForce GTX 960M)

/var/log/nvidia-installer.log.

chris@chris-HP:~ sudo uname -a [sudo] password for chris: Linux chris-HP 5.3.0-42-generic #34~18.04.1-Ubuntu SMP Fri Feb 28 13:42:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux chris@chris-HP:~ sudo inxi -SMCGx
System:
Host: chris-HP Kernel: 5.3.0-42-generic x86_64 bits: 64 compiler: gcc
v: 7.4.0 Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine:
Type: Laptop System: HP product: HP Pavilion Notebook
v: Type1ProductConfigId serial: 5CD6248S6B
Mobo: HP model: 820D v: 82.34 serial: PFYLT038J300FG UEFI: Insyde v: F.38
date: 05/24/2017
CPU:
Topology: Quad Core model: Intel Core i5-6300HQ bits: 64 type: MCP
arch: Skylake-S rev: 3 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18399
Speed: 901 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 900 2: 900
3: 900 4: 900
Graphics:
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel bus ID: 00:02.0
Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Hewlett-Packard
driver: N/A bus ID: 01:00.0
Display: server: X.Org 1.20.7 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
v: 4.5 Mesa 19.2.8 direct render: Yes
chris@chris-HP:~ sudo lspci -k | grep -A 2 -i "VGA" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) Subsystem: Hewlett-Packard Company HD Graphics 530 Kernel driver in use: i915 chris@chris-HP:~ sudo ls /etc/modprobe.d/
alsa-base.conf blacklist.conf blacklist-modem.conf dkms.conf
amd64-microcode-blacklist.conf blacklist-firewire.conf blacklist-oss.conf intel-microcode-blacklist.conf
blacklist-ath_pci.conf blacklist-framebuffer.conf blacklist-rare-network.conf iwlwifi.conf
chris@chris-HP:~ sudo sudo lshw -c video | grep 'configuration' configuration: latency=0 configuration: driver=i915 latency=0 chris@chris-HP:~ sudo xed /var/log/gpu-manager.log
sudo Rerun the gpu-manager.log

/var/log/nvidia-installer.log.

chris@chris-HP:~ sudo uname -a [sudo] password for chris: Linux chris-HP 5.3.0-42-generic #34~18.04.1-Ubuntu SMP Fri Feb 28 13:42:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux chris@chris-HP:~ sudo inxi -SMCGx
System:
Host: chris-HP Kernel: 5.3.0-42-generic x86_64 bits: 64 compiler: gcc
v: 7.4.0 Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine:
Type: Laptop System: HP product: HP Pavilion Notebook
v: Type1ProductConfigId serial: 5CD6248S6B
Mobo: HP model: 820D v: 82.34 serial: PFYLT038J300FG UEFI: Insyde v: F.38
date: 05/24/2017
CPU:
Topology: Quad Core model: Intel Core i5-6300HQ bits: 64 type: MCP
arch: Skylake-S rev: 3 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18399
Speed: 901 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 900 2: 900
3: 900 4: 900
Graphics:
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel bus ID: 00:02.0
Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Hewlett-Packard
driver: N/A bus ID: 01:00.0
Display: server: X.Org 1.20.7 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
v: 4.5 Mesa 19.2.8 direct render: Yes
chris@chris-HP:~ sudo lspci -k | grep -A 2 -i "VGA" 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) Subsystem: Hewlett-Packard Company HD Graphics 530 Kernel driver in use: i915 chris@chris-HP:~ sudo ls /etc/modprobe.d/
alsa-base.conf blacklist.conf blacklist-modem.conf dkms.conf
amd64-microcode-blacklist.conf blacklist-firewire.conf blacklist-oss.conf intel-microcode-blacklist.conf
blacklist-ath_pci.conf blacklist-framebuffer.conf blacklist-rare-network.conf iwlwifi.conf
chris@chris-HP:~ sudo sudo lshw -c video | grep 'configuration' configuration: latency=0 configuration: driver=i915 latency=0 chris@chris-HP:~ sudo xed /var/log/gpu-manager.log
sudo Rerun the gpu-manager.log

** (xed:5839): WARNING **: 19:04:57.492: Set document metadata failed: Setting attribute metadata::xed-position not supported
chris@chris-HP:~ sudo Rerun the gpu-manager.log sudo: Rerun: command not found chris@chris-HP:~
chris@chris-HP:~ sudo Rerun the gpu-manager.log sudo: Rerun: command not found chris@chris-HP:~ sudo gpu-manager.log
sudo: gpu-manager.log: command not found
chris@chris-HP:~ sudo rerun the gpu-manager.log sudo: rerun: command not found chris@chris-HP:~ sudo gpu-manager.log
sudo: gpu-manager.log: command not found
chris@chris-HP:~$ sudo xed /var/log/gpu-manager.log

** (xed:6272): WARNING **: 19:11:24.257: Set document metadata failed: Setting attribute metadata::xed-spell-language not supported

** (xed:6272): WARNING **: 19:11:24.258: Set document metadata failed: Setting attribute metadata::xed-encoding not supported
^C
chris@chris-HP:~$

** (xed:5839): WARNING **: 19:04:57.492: Set document metadata failed: Setting attribute metadata::xed-position not supported
chris@chris-HP:~ sudo Rerun the gpu-manager.log sudo: Rerun: command not found chris@chris-HP:~
chris@chris-HP:~ sudo Rerun the gpu-manager.log sudo: Rerun: command not found chris@chris-HP:~ sudo gpu-manager.log
sudo: gpu-manager.log: command not found
chris@chris-HP:~ sudo rerun the gpu-manager.log sudo: rerun: command not found chris@chris-HP:~ sudo gpu-manager.log
sudo: gpu-manager.log: command not found
chris@chris-HP:~$ sudo xed /var/log/gpu-manager.log

** (xed:6272): WARNING **: 19:11:24.257: Set document metadata failed: Setting attribute metadata::xed-spell-language not supported

** (xed:6272): WARNING **: 19:11:24.258: Set document metadata failed: Setting attribute metadata::xed-encoding not supported
^C
chris@chris-HP:~$

Please advise.

Thank you.

hpjuidW

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

I believe this is what you need generix. Please confirm. Thank you.

Please know that I am still a novice with Linux.

nvidia-bug-report.log (1.0 MB)

You have secure boot enabled so the driver doesn’t load, please disable secure boot in bios, then

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.
  • chris@chris-HP:~$ sudo apt install nvidia-prime
    [sudo] password for chris:
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    nvidia-prime is already the newest version (0.8.8.2).
    The following packages were automatically installed and are no longer required:
    libatomic1:i386 libbsd0:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386
    libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
    libelf1:i386 libexpat1:i386 libffi6:i386 libgl1:i386 libgl1-mesa-dri:i386
    libglapi-mesa:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386
    libllvm9:i386 libnvidia-common-430 libpciaccess0:i386 libsensors4:i386
    libstdc++6:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386
    libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
    libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
    libxfixes3:i386 libxshmfence1:i386 libxxf86vm1:i386 linux-headers-5.3.0-40
    linux-headers-5.3.0-40-generic linux-image-5.3.0-40-generic
    linux-modules-5.3.0-40-generic linux-modules-extra-5.3.0-40-generic
    Use ‘sudo apt autoremove’ to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • chris@chris-HP:~$ sudo prime-select nvidia
    Info: the nvidia profile is already set

  • chris@chris-HP:~$ sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf
    rm: cannot remove ‘/lib/modprobe.d/blacklist-nvidia.conf’: No such file or directory
    rm: cannot remove ‘/etc/modprobe.d/blacklist-nvidia.conf’: No such file or directory

  • sudo update-initramfs -u
    update-initramfs: Generating /boot/initrd.img-5.3.0-45-generic

I tried creating a new nvidia-bug-report.log. In the terminal it says that it does complete said action but the report does not show up in the files section.

I think I may have found the log. nvidia-bug-report.log (1.4 MB)

Generix, your solution has worked. Thank you. I did reboot they system. However, I do not have any icons on the monitor to select. Just the background picture.

Please advise.

Also, could you please tell me your method of fixing this problem, considering I am still learning and why the OS was not able to see the nvidia 435 driver? I would greatly appreciate it.

Thank you.

generix, I was able to get everything working properly. I can now see the information on my external monitor. If you could please tell me your method for correcting this error I would greatly appreciate it. Considering I’m still learning.

Thank you again.

generix, I will say that the overall picture display is a bit off. I have tried configuring the scaling but nothing seems to help. I believe this is because I am using an HDMI connection and that the monitor is 13 years old.

Maybe the monitor is in TV mode, please check its menu for an option ‘overscan’ or ‘underscan’ and toggle it.