PVD : "PVD file is invalid" or "PXD2 file is corrupted"

Howdy,

I’ve been working with physx (3.4.2) on a linux box and recently ran into a situation where PVD visualization would be helpful. I installed PVD on my windows box, and then ran my simulation on linux. The sim generated a 5ishMB .pvd file which I copied over to the windows box. I attempted to open it and was met with a “PVD file is invalid” error.

I varied setting up the transport with “.pvd” and “.pxd2” extensions (in case it helped) and tried varying the PxPvdInstrumentationFlag, but no permutations worked. Interestingly, pvd and pxd2 give different error messages (see title)

It seems someone else is also having this problem:
https://answers.unrealengine.com/questions/833127/physx-visual-debugger-open-pxd2-file-failed.html

Any ideas on what might be the cause of this? Or further things I should investigate?

Many Thanks!

Apologies for the delay in response. Would you be able to provide the PVD capture so we can take a look to identify what the problem is?

No problem. Here’s a dropbox link to one of the captures:

I think this might be because you are using joints (which are part of extensions) and you didn’t call PxInitExtensions() and provide a pointer to PVD. This call pushes metadata for the extensions types to PVD. Without this, PVD will crash if you use a type in extensions with PVD connected.

Hmm… that’s probably it. Thanks for looking into it.