Qt 5 install issues

Running ubuntu 16.04 LTS on Jetson Tx1
New to linux and Jetson

attempted to install Qt5 using sudo apt-get install qtquick1-5-dev

qtquick1-5-dev : Depends: qtbase5-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Tried to install qt5base-dev

The following packages have unmet dependencies:
qtbase5-dev : Depends: libgles2-mesa-dev but it is not going to be installed or
libgles2-dev but it is not installable
Depends: libqt5core5a (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5dbus5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5gui5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5network5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5printsupport5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5sql5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5test5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5widgets5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Depends: libqt5xml5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
Recommends: libqt5opengl5-dev (= 5.5.1+dfsg-16ubuntu7) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi z1photon,

We do not support QT officially, but other user can cross compiled the 5.7.1 successfully, please refer to below thread to see if can help on your project:
https://devtalk.nvidia.com/default/topic/980928/jetson-tx1/has-anyone-ever-gotten-cross-compiling-with-qt5-x-to-actually-work-/post/5046391/#5046391

Thanks