Raspberry Camera V2 via CSI with Jetson TX1, J100 carrier board

Until today, does anyone get success in using Raspberry camera V2 via CSI with jetson tx1? Carrier board is J100 AUVIDEA.

i tried to use gstreamer to capture video by Raspberry camera V2 but gst_nvcamera_open() failed.

We are working in the V4L2 driver for the raspberry camera v2.

At this point it is only possible to support other camera sensors through v4l2src and not nvcamerasrc. v4l2src bypasses the ISP so the frame that you would capture would be bayer. nvcamerasrc would require an special ISP configuration file and a driver for the camera as you can read here: https://devtalk.nvidia.com/default/topic/970967/isp-configuration-files/

We are working on both approaches but the driver is not ready yet. We are also using the J100 and the J20 from auvidea.

Hi DavidSoto,
Thank you very much. In my case, i also need bayer data only.
But when you connect raspberry camera v2 with J100, did you see /dev/video0?

You won’t see the /dev/video0 kernel node unless you have the driver for the camera, the driver not only set the correct value for the camera registers but also creates the kernel node.

At this point we see the sub device kernel node because the driver that we are creating already registers the camera with the main V4L2 driver but it is still not working to get frames, that is what we are solving right now. As soon as we are sure that all the IOCTLs of the driver are being called correctly we should be able to capture frames.

This information might be useful for you, we got the camera working:


Good news. Will binary driver be free with J100/J20 purchases? Have you tried more than one camera?

I have not read any multiple CSI-2 cameras working on TX1. We want to demonstrate multiple cameras on TX1

We have not tried more than one IMX219 yet, is one of the next steps. The driver is sold by RidgeRun.

As soon as we test with multiple cameras we will add the examples to the wiki as well.

We already added the support for multiple cameras and also to use the ISP to do the conversion from bayer to YUV. Check here:


Hi everyone.

I’m trying to connect J100 with TX1 and Pi camera v2.1 using jetpack 3.0, kernel 3.10.96.
I used current imx219 driver and create device tree for imx219 based one tegra210-platform/tegra210-camera-e3322-a00.dtsi cause i have to change i2c bus.
J100 has to connect Pi camera via CSI-A(CSI-B) and config camera with I2C-0(I2C-2) so i have to rewrite device tree for it and add it by using “Using Main Platform Device Tree File” method but the driver probe function stop and module crash right after function “imx219_parse_dt”.
Have anyone meet this before? Please give me some advices.
I have tried to write device tree for TC358743 using “Using Main Platform Device Tree File” method and it seem to work well with tc358743 driver i find in jetpack 3.1, kernel 4.4.38.