Raspberry Pi Camera v2.1 - Device not detected error thrown

Hi folks,
I have tried setting up the Jetson Nano today using the image from jetson-nano-sd-r32.1-2019-03-18.zip
I hooked up my working raspberry pi camera 2.1 and tried to check the camera with cheese
I am getting the message " No device detected " Error

I tried to pull out the camera from the pin and redo it and it did not resolve the purpose, nor a reboot after that

IS there any driver that is missing ? or something wrong else where…

Let me know what information you need from to diagnoze the problem

Can someone let me know how to fix this issue…

Thanks & Regards,
Shankar

hello kuchibhotla,

FYI, there are some cameras using the IMX219 that should work with Jetson-Nano.
https://github.com/NVIDIA-AI-IOT/jetbot/issues/29#issuecomment-481359800/

could you please attach kernel messages with below commands,

$ dmesg > klog.txt

please also check if there’s “i2c no acknowledge” failure.
thanks

Thanks Jerry,
I have been now able to use the camera , as described in the youtube video by Jim


You can go ahead and close the thread

Shankar

Sorry, please reopen. Though the raspberry pi camera works with the method described aboove, cheese still fails, and after updating to Opencv4 the face_detect.py program nolonger detects faces, and the ROS Melodic usb_cam node fails with a couldn’t query v4l fps error 25, Inappropriate ioctl for device.

Also though v4l has many features for CSI cameras, the MMAL drivers for the raspicam has many additonal features for motion tracking that make it invaluable for robotics.

Thank you for your indulgence.