Rendering Issue for Portrait Monitors


I posted an issue regarding displaying dual 4k@60 portrait monitors and it was suggested to post it here instead.

Anyone have a similar issue?

How about using a google doc or something else to share your picture?

What is your method to set monitor into portrait mode?

Thanks for the speedy reply.

I was able to take a short video depicting the issue.
It might be difficult to see since the framerate isn’t perfect, but you can see the screen flickering while the mouse moves and only areas where the mouse has moved over gets drawn.
It almost seems like the frame buffer isn’t getting updated properly. This occurs more easily when switching to pages with longer load times so perhaps the rendering of the DOM isn’t happening in time for xorg to draw it?

We set up the portrait modes using xrandr:

xrandr --ouput HDMI-0 --mode 3840x2160 --rate 59.98 --rotate left --ouput HDMI-1 --mode 3840x2160 --rate 59.98 --rotate left --right-of HDMI-0

I cannot see it clearly. Maybe the framerate does not match.

Is it possible to see this behavior with only the ubuntu desktop? Or must use your application?

What did you add to xorg.conf?

Sorry about that, the video is just a simple grid that should be displaying on the whole screen but only the parts that get hovered over by the mouse get displayed. (the rest remains plain grey)

We don’t have a desktop environment on our custom board so the only way to test at the moment is with our application.

Our current xorg.conf file just has some extra server flags.

Section "Module"
    Disable     "dri"
    SubSection  "extmod"
        Option  "omit xfree86-dga"

Section "Device"
    Identifier  "Tegra0"
    Driver      "nvidia"
    Option      "AllowEmptyInitialConfiguration" "true"
    Option      "TegraReserveDisplayBandwidth" "false"

Section "ServerFlags"
  Option "BlankTime" "0"
  Option "StandbyTime" "0"
  Option "SuspendTime" "0"
  Option "OffTime" "0"
  Option "DontVTSwitch" "on"
  Option "DontZoom" "on"


I tried setting ForceCompositionPipeline and TripleBuffer to "On" but the issue still occurs.

Please try to reproduce your issue with nv devkit environment. Or our team cannot check.

The devkit only has 1 HDMI output so I’m not sure I can reproduce it.
Maybe I can try to flash an ubuntu environment to see if I can reproduce it that way.

Please allow me some time to test a little more.
I was mostly just wondering if the TX2 had an performance differences or issues when displaying portrait vs landscape.
Thanks again for the quick assistance.


Sorry for my comment. I forgot this is TX2 platform. Do you have TX2-NX devkit or NX on your side to test?
Actually I think this is graphic configuration issue but not performance issue.

Also, any detail about your application? For example, is it using GL/EGL or something else to render?

Hi Wayne,

Sorry, we only have the devkit that comes with the TX2 with 1 HDMI port.

As for renderers, we are running a custom application over a qt browser, which I’ve heard has some compatibility issues with TX2 so I think we are just using the CPU. So it might be a performance issue on our end. Still not sure why portrait vs landscape would be different though.

It really feels like the very last frame buffer just isn’t getting output to the screen.
When the issue occurs, if I run the xrefresh command then everything gets displayed properly.
Do you know any xorg.conf settings that could help flush or force the frame buffer to display? Or perhaps some nvidia driver options that can help with display performance or buffering?

Have you run jetson clocks? If this is pure cpu work, then jetson clocks should push the perf.

Thanks for the tip. Running the jetson clocks script does seem to solve the issue.
I’m not sure that it’s something we can use long term so we’ll have to find a workaround, but I guess that does confirm the issue.

If you have any other suggestions to try that would be appreciated. Otherwise I’ll accept this as the solution.

Thanks again for the speedy support!